Ask Your Question
1

rosjava on android emulator

asked 2012-03-19 20:48:49 -0500

markkre gravatar image

Hello people!

Has anyone ever tried to run a rosjava app on an android emulator, with the ros-master on the host system (not on the emulator)? I need such a configuration, but I don't know how to set it up.

greets

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-03-27 02:26:33 -0500

damonkohler gravatar image

I do not recommend using the Android emulator (performance is really bad). In theory, you could set things up using adb port forwarding: http://developer.android.com/guide/developing/tools/adb.html#forwardports

In practice, this isn't really possible since rosjava does not currently allow you to configure port ranges that should be used. Please file a feature request if that is something you need: http://code.google.com/p/rosjava/issues/list

edit flag offensive delete link more

Comments

Thank you for the hint! I already tried several emulator networking stuff on that website you posted. Now I know why nothing worked ;) Well, sometimes it would be handy having an emulator capable of ROS stuff ...

markkre gravatar imagemarkkre ( 2012-03-28 21:26:10 -0500 )edit
1

answered 2014-04-10 21:52:26 -0500

MR gravatar image

hi,

i'am working on the same problem. I want to connect the pub_sub_tutorial_app from android emulator to roscore on the same machine. It seems that's not a problem to connect from emulator to roscore with the alias ip 10.0.2.2 because i can see the nodes in the nodelist. But roscore can't find the emulator. Ok, that's similar to this post: http://answers.ros.org/question/10479... (SebastianMuszynski).

However, when i use the clockwork tether app to get internet access on my computer everything works (almost) fine. So i can connect from emulator to roscore and back (i can see Hello World message and counter in the emulator). But i don't understand why this works!!! At my point of view i think there is something with a tun interface and adb port forwarding (i can see some initialisations in the command window of the Tether program)... The only problem is, that sometimes the tether app pops up in the emulator and nothing works so i want to reproduce this without the app..

Does anyone know why this works? I wanna understand this but currently i can't...

@damonkohler: I don't understand why this isn't really possible! Please can you give me another chance to understand this?

Thanks!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-03-19 20:48:49 -0500

Seen: 867 times

Last updated: Apr 10 '14