Ask Your Question
0

Warning "No map received" occurs.

asked 2018-07-24 09:03:10 -0600

Miaow gravatar image

Hello.I'm trying to use slam_karto.

But when I try to see the visual map in the Rviz ,the map model warns 'no map recevied'.

I can see the LaserScan.And the dataset can run correctly on 'gmapping slam_gmapping.

I'm sure the topic name is used rightly.

My step:

rosrun slam_karto  slam_karto
rosbag play catkin_ws/data/inter.bag

When I play the inter.bag,slam_karto prints these:

...
LaserRangeScan contains 180 range readings, expected 181
LaserRangeScan contains 180 range readings, expected 181
LaserRangeScan contains 180 range readings, expected 181
...

Up to now , I still confuse how to use slam_karto to run dataset.

Can you help me?

edit retag flag offensive close merge delete

Comments

It seems you dont have karto configured correctly.

stevemacenski gravatar image stevemacenski  ( 2018-07-24 19:23:06 -0600 )edit

Do you means I dont install karto correctly?I just clone karto_slam from github not open_karto,is it wrong?

Miaow gravatar image Miaow  ( 2018-07-24 20:12:17 -0600 )edit
1

Karto is fine but look at the error you're seeing. What does it mean?

Hint: some of the meta data in your laser scan message is probably incorrect. Here's where your error lies

https://github.com/ros-perception/ope...

stevemacenski gravatar image stevemacenski  ( 2018-07-25 00:38:52 -0600 )edit

Thank you a lot!I think that's the key! I dont find corresponding dataset,so I download from there and transform '.clf' to '.bag'. Could you tell me where I can download the right dataset?Thanks!

Miaow gravatar image Miaow  ( 2018-07-25 00:47:47 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-07-25 01:09:50 -0600

(moving to answer so I can have more characters) I think you need to change the expected number of readings, clearly its off by 1. Alternatively, you can turn off this check since you have installed from source by commenting it out. My guess is that you're not getting the right number of readings and that checker is throwing out all the data. Your options are to 1) configure karto for the right number 2) pre-process the bag file data to have the meta data updated or add a 0 reading at end 3) comment out the check and let it pass with 1 less than expected.

edit flag offensive delete link more

Comments

Thanks for your attention and patience! I take your 2nd suggestion and solve it!

Miaow gravatar image Miaow  ( 2018-07-25 01:27:33 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-07-24 09:03:10 -0600

Seen: 499 times

Last updated: Jul 25 '18