error launching slam karto on indigo

asked 2016-03-06 03:45:53 -0500

stevej_80 gravatar image

updated 2016-03-08 02:24:47 -0500

Hello

I tried to install and run SLAM KARTO but i am getting an error when trying to run the karto node.

i cloned and compiled the code locally and I ran into the problems that are mentioned here and here (yes both of them) and could not fix them. So I cleaned up everything and this time installed SLAM Karto using apt-get install ros-indigo-slam-karto and now when i try to run the node it throws this memory allocation error:

*** Error in `/opt/ros/indigo/lib/slam_karto/slam_karto': malloc(): memory corruption: 0x08508518 ***
Aborted (core dumped)

what could be wrong with this package?! system is running on Ubuntu 14.04 + ros Indigo.

Thanks for helps!

edit retag flag offensive close merge delete

Comments

I got this memory corruption error too today on a fresh ROS Indigo installation on an older laptop of mine. It still works fine on a Virtual Machine, where I first tried it.

spmaniato gravatar imagespmaniato ( 2016-04-14 14:53:10 -0500 )edit

@spamaniato I couldn't get it to work any where. Although on Hydro I dont get the error when i launch the karto but nothing happens after launch either. weird!

stevej_80 gravatar imagestevej_80 ( 2016-04-14 22:04:24 -0500 )edit

About nothing happening after you launch slam_karto: that may be normal. It will remain idle until it receives LaserScan messages. My recommendation (for testing purposes) would be to record /scan and /tf messages in a bagfile. Then, launch slam_karto and play the bagfile.

spmaniato gravatar imagespmaniato ( 2016-04-15 09:00:10 -0500 )edit

Of course I am publishing LaserScan messages and necessary transforms and still nothing happens, otherwise why would it be weird ;-)

stevej_80 gravatar imagestevej_80 ( 2016-04-17 03:54:05 -0500 )edit

Adding some more info: I got a similar error on Mac OS X, where I built SBA, open_karto, and slam_karto form source: slam_karto(48584,0x700000499000) malloc: *** error for object 0x7fccd5001670: incorrect checksum for freed object - object was probably modified after being freed.

spmaniato gravatar imagespmaniato ( 2016-04-24 11:51:04 -0500 )edit