Ask Your Question
0

problems launching slam_karto (ros-hydro)

asked 2015-01-27 04:23:40 -0500

AlexR gravatar image

Hi ,

I am getting problems trying to run the slam_karto package. First of all, the wiki page isn't updated for the karto slam. So I tried to look into the github for a possible ros hydro package. Found the one maintained by Mike Ferguson slam_karto.

Got the package into the catkin folder and build it with few errors about dependencies on g2o and SBA. Figured out from this repository github link. Everything build nicely with no errors.

I also found there is an apt-get package for slam_karto.

I run :

sudo apt-get install ros-hydro-slam-karto 

sudo apt-get install ros-hydro-open-karto

Then, I sourced all the files properly from the /caktin_ws/devel/setup.bash and /opt/ros/hydro/setup.bash

But when running roslaunch slam_karto karto_slam.launch

I get the following error:

ERROR: cannot launch node of type [karto/slam_karto]: can't locate node [slam_karto] in package [karto]

Now, I am not sure where to look for this node? and how do I resolve this error and run the karto.

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2015-01-27 04:48:31 -0500

Sebastian Kasperski gravatar image

This looks pretty much like the same problem as in your last question. When you install a package both from source and from apt-get, you should make sure that the correct one is used. (check with "roscd slam_karto") You probably have to remove the source packages from your ROS-Path when you want to use the apt-get-installed ones.

edit flag offensive delete link more

Comments

roscd slam_karto gave me the following :~/catkin_ws/src/slam_karto/slam_karto

so in a way the path is correctly defined. (I removed the packages from the /opt/ros/hydro/share) and only have the sourced packages...

AlexR gravatar image AlexR  ( 2015-01-27 05:37:47 -0500 )edit

You probably have to execute: "source ~/catkin_ws/devel/setup.bash" once again after building for the first time.

Sebastian Kasperski gravatar image Sebastian Kasperski  ( 2015-01-27 06:36:32 -0500 )edit

i did sourced after running catkin_make. I am getting the same error.

what is the difference between ros node and ros driver?

AlexR gravatar image AlexR  ( 2015-01-28 22:31:07 -0500 )edit

Check whether the node executables are available in /catkin_ws/devel/lib/. Else there might have been an error while building. Where did you read ros driver?

Sebastian Kasperski gravatar image Sebastian Kasperski  ( 2015-01-29 02:40:57 -0500 )edit
0

answered 2015-12-23 02:37:24 -0500

张京林 gravatar image

updated 2015-12-23 02:37:46 -0500

If you install from source, you need to change the karto_slam.launch in catkin_ws/src/slam_karto/launch:
The package name is wrong in the launch file
<node pkg="karto" type="slam_karto" name="slam_karto" output="screen">

Please change the pkg="karto" to pkg="slam_karto",so that the launch file could find the node in slam_karto package.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-01-27 04:23:40 -0500

Seen: 912 times

Last updated: Dec 23 '15