Ask Your Question
0

Could not get data streaming from Kinect using openni_launch

asked 2018-07-11 22:10:43 -0600

hafiz143 gravatar image

Hello, I have a Kinect XBOX360 attached to a Ubuntu 16.04 on ROS Kinetic. I have installed OpenNI and SensorKinect as described in https://www.20papercups.net/programmi... . I could not get the data from the sensor when launching:

roslaunch openni_launch openni.launch

I also tried to visualize using rviz and follow the guidelines in http://wiki.ros.org/openni_launch/Tut... but nothing is showing up.

The message I get after running roslauch was:

... logging to /home/iman/.ros/log/e62e5f62-84b5-11e8-869e-002618390022/roslaunch-iman-K40IJ-32383.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://iman-K40IJ:39059/

SUMMARY
========

PARAMETERS
 * /camera/camera_nodelet_manager/num_worker_threads: 4
 * /camera/depth_rectify_depth/interpolation: 0
 * /camera/depth_registered_rectify_depth/interpolation: 0
 * /camera/disparity_depth/max_range: 4.0
 * /camera/disparity_depth/min_range: 0.5
 * /camera/disparity_registered_hw/max_range: 4.0
 * /camera/disparity_registered_hw/min_range: 0.5
 * /camera/disparity_registered_sw/max_range: 4.0
 * /camera/disparity_registered_sw/min_range: 0.5
 * /camera/driver/depth_camera_info_url: 
 * /camera/driver/depth_frame_id: camera_depth_opti...
 * /camera/driver/depth_registration: False
 * /camera/driver/device_id: #1
 * /camera/driver/rgb_camera_info_url: 
 * /camera/driver/rgb_frame_id: camera_rgb_optica...
 * /rosdistro: kinetic
 * /rosversion: 1.12.13

NODES
  /camera/
    camera_nodelet_manager (nodelet/nodelet)
    depth_metric (nodelet/nodelet)
    depth_metric_rect (nodelet/nodelet)
    depth_points (nodelet/nodelet)
    depth_rectify_depth (nodelet/nodelet)
    depth_registered_hw_metric_rect (nodelet/nodelet)
    depth_registered_metric (nodelet/nodelet)
    depth_registered_rectify_depth (nodelet/nodelet)
    depth_registered_sw_metric_rect (nodelet/nodelet)
    disparity_depth (nodelet/nodelet)
    disparity_registered_hw (nodelet/nodelet)
    disparity_registered_sw (nodelet/nodelet)
    driver (nodelet/nodelet)
    ir_rectify_ir (nodelet/nodelet)
    points_xyzrgb_hw_registered (nodelet/nodelet)
    points_xyzrgb_sw_registered (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
    rgb_debayer (nodelet/nodelet)
    rgb_rectify_color (nodelet/nodelet)
    rgb_rectify_mono (nodelet/nodelet)
  /
    camera_base_link (tf2_ros/static_transform_publisher)
    camera_base_link1 (tf2_ros/static_transform_publisher)
    camera_base_link2 (tf2_ros/static_transform_publisher)
    camera_base_link3 (tf2_ros/static_transform_publisher)

ROS_MASTER_URI=http://localhost:11311

process[camera/camera_nodelet_manager-1]: started with pid [32400]
process[camera/driver-2]: started with pid [32401]
process[camera/rgb_debayer-3]: started with pid [32402]
process[camera/rgb_rectify_mono-4]: started with pid [32414]
process[camera/rgb_rectify_color-5]: started with pid [32430]
process[camera/ir_rectify_ir-6]: started with pid [32437]
[ INFO] [1531363197.790392184]: Initializing nodelet with 4 worker threads.
process[camera/depth_rectify_depth-7]: started with pid [32450]
process[camera/depth_metric_rect-8]: started with pid [32472]
process[camera/depth_metric-9]: started with pid [32483]
process[camera/depth_points-10]: started with pid [32485]
process[camera/register_depth_rgb-11]: started with pid [32502]
process[camera/points_xyzrgb_sw_registered-12]: started with pid [32514]
process[camera/depth_registered_sw_metric_rect-13]: started with pid [32530]
process[camera/depth_registered_rectify_depth-14]: started with pid [32535]
process[camera/points_xyzrgb_hw_registered-15]: started with pid [32557]
process[camera/depth_registered_hw_metric_rect-16]: started with pid [32560]
process[camera/depth_registered_metric-17]: started with pid [32575]
process[camera/disparity_depth-18]: started with pid [32583]
process[camera/disparity_registered_sw-19]: started with pid [32586]
process[camera/disparity_registered_hw-20]: started with pid [32598]
process[camera_base_link-21]: started with pid [32621]
process[camera_base_link1-22]: started with pid [32626]
process[camera_base_link2-23]: started with pid [32651]
process[camera_base_link3-24]: started with pid [32674]
Warning: USB events thread - failed to set priority. This might cause loss of data...
[ INFO] [1531363200.803957315]: Number devices connected: 2
[ INFO] [1531363200.905855798]: 1. device on bus 002:26 is a SensorKinect (2ae) from PrimeSense (45e) with serial id '0'
[ INFO] [1531363200.905994363]: 2. device on bus 002:26 is a SensorV2 (2ae) from PrimeSense (45e) with serial id 'A00361A17605136A'
[ INFO] [1531363200.908275929 ...
(more)
edit retag flag offensive close merge delete

Comments

Hello! Seeing that nobody gives an answer, i will try to help something! I worked on that like 1 year ago and i was using Indigo. After checking the first link you sent, i see that everybody there is using ubuntu 14.04 or 15.04 and ROS Indigo.

Solrac3589 gravatar imageSolrac3589 ( 2018-07-12 10:04:23 -0600 )edit

I remember when i was playing on that, that the library was quite outdated. maybe there is no support with your ros version right know. Anyway, i have a friend who i think is playing on that, and i will ask him to check that. Hope it helps! edit: my friend is usig orbec, not kinect, so he cannot hel

Solrac3589 gravatar imageSolrac3589 ( 2018-07-12 10:05:34 -0600 )edit

@Solrac3589 thanks so much! Yes do ask your friend. Installing Indigo is a workaround for now, which is cool.

hafiz143 gravatar imagehafiz143 ( 2018-07-12 10:13:19 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-13 00:14:02 -0600

hafiz143 gravatar image

I have worked around this issue based on the post discussion here

The issue is solved when I uninstall the SensorKinect driver I cloned from here. The work around it is to uninstall the SensorKinect driver by running:

. ~/SensorKinect/Platform/Linux/Redist/Sensor-Bin-Linux-x64-v5.1.2.1/install.sh -u

asssuming that SensorKinect is installed in the Home directory.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-11 22:10:43 -0600

Seen: 54 times

Last updated: Jul 11 '18