Can't install RealSense driver ???

asked 2018-07-04 12:27:52 -0500

-LD- gravatar image

Hello everyone,

i'm still new to ros and also Linux. I'm supposed to work with a RealSense camera. So i tried the same as i did with the other HW i'm using so far. Google if there is something predefined for ROS on wiki.ROS. As far as i understood things so far it's supposed to work like this:

  • get "librealsense" to work somehow, maybe also "librealsense2"
  • after that, try the same with "realsense_camera" and also maybe "realsense2_camera"
  • (in that order, since the second package depends on the first one)

to do the first, i tried following the instructions here: http://wiki.ros.org/librealsense

  • 2.2.1 Enable Kernel Sources: worked without any visible problems (i guess? can't check)
  • 2.2.2 Update to the Xenial kernel: same. No problems while rebooting
  • 2.2.3 Re-install Package: ehm, this one sounds wrong. Don't i have to try to install it first before concerning about reinstalling it?

But there isn't mentioned how to install it. Therefore the following error is not really surprising for me.

$ sudo apt-get --reinstall install 'ros-*-librealsense'
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-*-librealsense
E: Couldn't find any package by regex 'ros-*-librealsense'

So, now the question is, what should i do now? Since this was the third tutorial i tried to follow (each ending in different errors) i'm not sure what file have been installed and which ones are missing. Any hints how to check what has been installed successfully and even more important, how to get the node ready and running? I kind of got lost what has been done and what might be missing.

System running:

$ cat /etc/*release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.5 LTS"
NAME="Ubuntu"
VERSION="14.04.5 LTS, Trusty Tahr"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 14.04.5 LTS"
VERSION_ID="14.04"

And the Kernel should be:

$ uname -r
4.4.0-130-generic

And last the ROS version:

$ rosversion -d
indigo
edit retag flag offensive close merge delete

Comments

1

I would recommend posting this to intel-ros/realsense/issues, as it's an issue with / question about packaging. The Intel devs are quite active.

gvdhoorn gravatar imagegvdhoorn ( 2018-07-05 02:50:36 -0500 )edit