Ask Your Question
0

hector_slam how to disable tf ?

asked 2018-07-01 12:26:13 -0500

kesuke gravatar image

hi ,

i'm trying to get odometry from hector_slam bu using hokuyo laser because the odometry that i'm getting from wheel encoder is not so good , so i configured the hector_slam and i'm getting a good odometry data but the problem is that despite i put
it's still publishing trasnformation from map to odom and i don't want it because amcl is already publishing it , i want only the odometry data not the tf , somemone can tell me how to deal with it ? here is the launch file i'm using to get odometry from hector_slam :

<launch>
<node pkg="hector_mapping" type="hector_mapping" name="hector_mapping" output="screen">
<remap from="map" to="hector_map"/>
<remap from="scanmatch_odom" to="odom_hector"/>
<remap from="initialpose" to="trash_initialpose"/>
<param name="tf_map_scanmatch_transform_frame_name" value="odom" />
<param name="pub_map_odom_transform" value="false"/>
<param name="pub_odometry" value="true" />
<param name="base_frame" value="base_link"/>
<param name="odom_frame" value="odom"/>
<param name="output_timing" value="false"/>    
<param name="use_tf_scan_transformation" value="true"/>
<param name="use_tf_pose_start_estimate" value="false"/>
<param name="scan_topic" value="scan"/>

<!-- Map size / start point -->
<param name="map_resolution" value="0.050"/>
<param name="map_size" value="2048"/>
<param name="map_start_x" value="0.5"/>
<param name="map_start_y" value="0.5" />

<!-- Map update parameters -->
<param name="update_factor_free" value="0.4"/>
<param name="update_factor_occupied" value="0.9" />    
<param name="map_update_distance_thresh" value="0.4"/>
<param name="map_update_angle_thresh" value="0.06" />
<remap from="map" to="maphector"/>
</node>
<node pkg="topic_tools" type="throttle" name="map_throttle" args="messages map 0.1 throttled_map" />
</launch>
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-02 02:42:56 -0500

kartikmohta gravatar image

There is another parameter pub_map_scanmatch_transform which enables the publishing of tf from map to the frame named in param "tf_map_scanmatch_transform_frame_name". So just add

<param name="pub_map_scanmatch_transform" value="false"/>

to disable that.

edit flag offensive delete link more

Comments

@kartikmohta thank you so much it's working

kesuke gravatar image kesuke  ( 2018-07-02 03:11:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-07-01 12:26:13 -0500

Seen: 314 times

Last updated: Jul 02 '18