Ask Your Question
0

Problem with husky_rviz, no tf data

asked 2018-06-27 18:40:35 -0600

frodyteen gravatar image

updated 2018-06-28 14:42:04 -0600

I am working with ubuntu 14.04 indigo. I followed this tutorial and ran the husky_gazebo launch file first then the husky_rviz launch file. However, I cannot see the husky model shown in the tutorial in rviz. In the display panel, it shows me a No tf data. Actual error: Fixed Frame [odom] does not exist in the global status. Also, the robotModel status is an error as well.

The only thing that I did differently then the tutorial is that I downloaded the all the gazebo models from this link, and moved all files to ~/.gazebo/models/ folder. Also, instead of running roscore, I am running sudo service husky-core start on the actually Husky robot.

here is a screen shot of the gazebo view panel: image description

rviz view panel:

image description

anyone have any suggestions on how to fix this?

tf tree:

image description

update: When I first turn on the husky robot and starts the husky-core, then roslaunch husky_viz view.robot.launch, everything works fine in rviz. When I move the joystick controller, the actually husky moves and the simulated husky in rviz moves as well. Now, I am trying to use gazebo to simulate the husky by roslaunch husky_gazebo husky_empty_world.launch, then roslaunch husky_viz view_robot.launch, but the husky model does not show up in rviz.

edit retag flag offensive close merge delete

Comments

Can you post your tf tree?

jayess gravatar imagejayess ( 2018-06-27 21:18:56 -0600 )edit

I added it, but it just shows no tf data received.

frodyteen gravatar imagefrodyteen ( 2018-06-27 21:37:40 -0600 )edit

husky_gazebo , when you launch this , see to it that all the nodes are launched properly . Sometimes if dependencies are not installed , usually stuff like this happens .

chrissunny94 gravatar imagechrissunny94 ( 2018-06-28 09:28:14 -0600 )edit

I checked with rosdep check husky_gazeborosdep check husky_viz and it shows me that all the dependency are satisfied. Also, I downloaded those packets by sudo apt-get install

frodyteen gravatar imagefrodyteen ( 2018-06-28 14:26:09 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-06-28 15:09:22 -0600

frodyteen gravatar image

Turns out, I need to be using roscore instead of the actually husky-core inorder for the husky_gazebo and husky_viz to work. So, I followed this link and configured my network, then everything works.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-27 18:40:35 -0600

Seen: 674 times

Last updated: Jun 28 '18