Ask Your Question
0

Workspace not properly overlayed by setup script

asked 2018-06-07 16:53:38 -0500

devolutor gravatar image

updated 2018-06-07 17:33:23 -0500

gvdhoorn gravatar image

First day with ROS, trying to configure the environment and following the beginner tutorial here:

http://wiki.ros.org/ROS/Tutorials/Ins...

Everything seemed to be working up until this point, I was able to create the catkin workspace.

$ mkdir -p ~/catkin_ws/src
$ cd ~/catkin_ws
$ catkin_make

These commands work and I was able to create the catkin workspace.

And I don't get an error when I run:

$ source devel/setup.bash

However, now when I run:

$ echo $ROS_PACKAGE_PATH
/home/youruser/catkin_ws/src:/opt/ros/kinetic/share

I get the error:

bash: /home/youruser/catkin_ws/src:/opt/ros/kinetic/share: No such file or directory

If it helps, I am running Linux Ubuntu 16.04 on Oracle VM VirtualBox

Any help with this would be greatly appreciated. Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2018-06-08 09:18:54 -0500

nathan gravatar image

I think your workspace is not overlaying the ROS install correctly. To fix this, I propose doing the following:

  1. cd ~/catkin_ws
  2. rm -rf build/ devel/
  3. source /opt/ros/kinetic/setup.bash (replace "kinetic" with the ROS version that you are using)
  4. (while in catkin_ws/) catkin_make
  5. source devel/setup.bash

I think that you forgot step 3 before you evoked catkin_make for your workspace. In that case, the search path does not include the installed ROS packages.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-07 16:53:38 -0500

Seen: 950 times

Last updated: Jun 08 '18