ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

TF problem when using camera

asked 2018-06-05 08:16:07 -0500

saurabh gravatar image

updated 2018-06-05 08:16:52 -0500

Hello All,

I am using Intel D415 for my robot. I have interfaced this camera in my robot with URDF. I am also able to generate the PointClouds and able to watch in RViz.

But here I am facing an issue. Whenever I launch camera node with RViz, TF goes bad, and it is showing the PointClouds direction somewhere else. This is a random behaviour. Sometime I get PointClouds in correct direction, in actual camera direction. I can clearly see that, when camera node is launched TF for sensor links goes bad, and showing somewhere else.

There may be 2 reasons for this problem:

  1. Frame Rate: I am using the Frame Rate to be 30fps. May be because of high data rate, TF is going bad

  2. URDF: I have defined camera links in my URDF. And these links have same names as needed from camera node. So there it is having some mis-match.

Can someone please let me know how to debug this issue. I am trying to change the frame rate to some lower value, but that is taking sometime and I asked support from Intel.


edit retag flag offensive close merge delete


Try roswtf to see if you have competing sources for the same tf frames.

lucasw gravatar image lucasw  ( 2018-06-05 11:52:01 -0500 )edit

"And these links have same names as needed from camera node", This is probably the cause of your problem. If two nodes are broadcasting the same transform with different values things go a bit strange. As @locasw said roswtf will highlight this for you if it's the problem.

PeteBlackerThe3rd gravatar image PeteBlackerThe3rd  ( 2018-06-05 12:46:21 -0500 )edit

Hello Pete, thanks for your input. Actually problem is same, broadcasting tf from 2 sources. In realsense_camera, I was able to disable the publish_tf, but upgraded package i.e. realsense2_camera doesn't seem to be having this feature. Asked Intel to provide some equivalent.

saurabh gravatar image saurabh  ( 2018-06-06 02:57:30 -0500 )edit

Can you remove the redundant tf frame from your urdf?

lucasw gravatar image lucasw  ( 2018-06-07 11:59:23 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-06-07 13:57:11 -0500

saurabh gravatar image

Hello Pete,

Thanks for your response, actually the problem was the same. There was multiple broadcasting of the TF. So I removed the TF broadcast from camera.

@Lucas, I think its not a better idea to remove the redundant tf from my urdf, though I have not tried it. As camera info is having the field for frames, it corresponds to. So I think in URDF we should be having the corresponding frames. And we should stop tf broadcasting from camera. As there should be some binding between camera and my urdf.

If rather removing TF broadcast from camera, if I remove corresponding frames, then broadcasted tf will not having any information, where each frame is positioned in urdf.

Thats why, I removed tf broadcast from camera only. And that actually worked.

With best regards, Saurabh

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2018-06-05 08:16:07 -0500

Seen: 932 times

Last updated: Jun 07 '18