Ask Your Question
1

ROS + Intel Galileo + RPlidar not working, but gives OK health status

asked 2014-10-05 15:05:03 -0600

sanmarh gravatar image

Heya all, hopefully some of you can help me with this frustrating problem.

I am working with the project where I need to get indoor navigation data using RPlidar. The lidar is working fine with ROS when I'm connecting it to the development PC, but the idea is to get it running on Intel Galileo. RPlidar ROS package is installed with the instruction here: https://github.com/robopeak/rplidar_ros

Currently, Intel Galileo has Debian running without problems (installation instruction from the Wiki) and RPlidar is connected to the board with GPIO pins. The lanch file has been modified that serial_port is changed from default /dev/ttyUSB0 -> /dev/ttyS0 and all GPIO pins have been configured with the instructions shown here: http://www.malinov.com/Home/sergey-s-...

ROS is running fine and RPlidar power led is on (but the actual motor is NOT spinning the lidar, so it is not working). When I'm launching the rplidar node with roslaunch rplidar_ros rplidar.launch there is no problems - health code is 0 and everything seems to be working. However, when I try to get data with rosrun rplidar_ros rplidarNodeClient - nothing happens. No errors, no warnings, nothing. And as I stated in previous command, everything seems to be normal - except from the motor is not running.

I tried to search for the solution without success, but I have absolutely no clue why it does not run. Have I done something fundamentally wrong or is there some major issues with rplidar package and Intel Galileo?

Looking forward to the solution and your respected help.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-11-06 09:30:22 -0600

mrsoft99 gravatar image

I had a similar, but not exactly the same, issue running rplidar on a raspberry pi B+, using ros hydro I built from source.

My problem was resolved by using a powered USB hub for the rplidar. So try disconnecting the rplidar from the usb on the galileo, connect a powered usb hub to galileo, and the rplidar to the powered usb hub.

My issue also was led was on and system indicated good health, but no data. Although in my case, the motor was spinning!.

For me, perhaps either the power supply I was using for the B+ pi board wasn't big enough, or the B+ board itself has an issue with current needs of the rplidar, perhaps regarding starting the motor.

edit flag offensive delete link more

Comments

Hi, Do you have the procedure, or the links to the tuto that you use to install the RPlidar on your raspberry ? Because, I tried to install it on my rapsberry, but I have problem with instalation of ROS..

thank you in advance

Salmosa gravatar imageSalmosa ( 2015-01-06 12:53:12 -0600 )edit
0

answered 2014-10-19 22:18:05 -0600

jordan gravatar image

You may already be aware of this: The motor is enabled by the RS232 DTR signal (so I read in another post). Have you checked it?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-05 15:01:11 -0600

Seen: 1,296 times

Last updated: Nov 06 '14