Ask Your Question
0

Hector exploration costmap get robot pose error

asked 2018-05-25 08:47:00 -0600

frozt gravatar image

updated 2018-05-25 11:02:56 -0600

Hi, i connect an rplidar to ubuntu 16.04 with ros-kinetic. I'm using hector_navigation to get path planning. I use roslaunch rplidar_ros view_slam.launch and roslaunch hector_exploration_node exploration_planner.launch but exploration planner gives could not get robor pose error. I only have rplidar connect no additional sensors or robot.

[ WARN] [1527263734.508645133]: Could not get robot pose, cancelling reconfiguration
[ WARN] [1527263735.608135645]: Costmap2DROS transform timeout. Current time: 1527263735.6081, global_pose stamp: 1527263735.3022, tolerance: 0.3000
edit retag flag offensive close merge delete

Comments

have you solved this problem?

aarontan gravatar image aarontan  ( 2018-07-26 19:37:07 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-05-25 11:26:35 -0600

frozt gravatar image

updated 2018-05-25 13:36:15 -0600

I solved the problem by uncommenting transform_tolerance variable in hector_exploration_node/config/costmap.yaml

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-25 08:47:00 -0600

Seen: 394 times

Last updated: May 25 '18