ERROR: cannot launch node of type [rviz/rviz]: can't locate node [rviz] in package [rviz] [closed]

asked 2018-09-26 23:28:36 -0600

Clark gravatar image

Hi guys, I'm using raspberry pi 3B to run rplidar and show the scanning result through rviz, however, I follow the github rplidar lesson but when I execute "roslaunch rplidar_ros view_rplidar.launch" this command, it always show up "ERROR: cannot launch node of type [rviz/rviz]: can't locate node [rviz] in package [rviz]", therefore, I try to do "rviz rviz" to check rviz, then it can open rviz successfully.

Also I'v tried 1.roslaunch rplidar_ros rplidar.launch 2.rosrun rplidar_ros rplidarNodeClient, it worked successfully to read the information form lidar and show on terminal.

Please help me :( thanks in advance!

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Clark
close date 2019-06-24 22:50:06.102401

Comments

does rosrun rviz rviz startup rviz or not. I don't get that in your question.

If not, is it installed? (sudo apt install ros-kinetic-rviz on UbuntuMate; which OS are you using btw?)

mgruhler gravatar imagemgruhler ( 2018-09-27 01:32:01 -0600 )edit

Yes, if type "rosrun rviz rviz", rviz can open successfully. But when I type "roslaunch rplidar_ros view_rplidar.launch", this error happened, and rviz didn't open automatically. p.s. I follow this website link text and my OS is raspbian stretch,thanks.

Clark gravatar imageClark ( 2018-09-27 02:21:21 -0600 )edit

for some reason it is unable to find config file in rplidar_ros package. You can load it using rviz. File -> Open config, and then navigate to rviz config in package.

Choco93 gravatar imageChoco93 ( 2018-09-27 02:29:07 -0600 )edit

Try opening a new terminal, source ROS install folder and your workspace. Something like source /opt/ros/kinetic/setup.bash and source ~/catkin_ws/devel/setup.bash . And try launching view_rplidar.launch again.

Reamees gravatar imageReamees ( 2018-09-27 02:34:07 -0600 )edit

@Choco93 , I found a file rplidar.rviz under rplidar_ros package and open it like you told me, but it shows nothing...

@Reamees, I'v tried this many times but it didn't work... is there any possible problem?

Clark gravatar imageClark ( 2018-09-27 03:49:16 -0600 )edit

was rplidar node running when you changed configuratin of rviz? Is your node is working in general like are you getting topics? Does those topics have data?

Choco93 gravatar imageChoco93 ( 2018-09-27 04:37:58 -0600 )edit

Still can not, finally I changed the method, which is run rviz on my dsktop to receive data from lidar, and it worked perfectly.. still thanks :)

Clark gravatar imageClark ( 2018-10-02 03:15:20 -0600 )edit