Ask Your Question
1

MoveIt! Benchmarking issue

asked 2018-05-23 10:54:15 -0500

enrico gravatar image

Hi all,

I have faced a problem when trying to apply the benchmarking to my robot (UR5). Initially I followed the tutorial which is on Fanuc and it works because you don't have to create packages or launch files since everything is already there. I copied the "benchmarks" folder which contains -> examples -> demo1.yaml and demo_fanuc.launch (and I modified them properly to adapt to my robot). After that I was able to connect to database and saving scene and query. Everything works until I run the benchmark [roslaunch moveit_ros_benchmarks demo_fanuc.launch]. The error is the following:

[ INFO] [1527089331.704758889]: Loaded queries successfully
[ INFO] [1527089331.704794510]: Benchmark loaded 1 starts, 0 goals, 0 path constraints, 0 trajectory constraints, and 1 
queries
[ INFO] [1527089331.704935837]: Benchmarking query 'Start2_Pick2' (1 of 1)

0%   10   20   30   40   50   60   70   80   90   100%
|----|----|----|----|----|----|----|----|----|----|
Debug:   Starting goal sampling thread
Debug:   Waiting for space information to be set up before the sampling thread can begin computation...
[ INFO] [1527089331.705864397]: Planner configuration 'manipulator[RRTConnectkConfigDefault]' will use planner 'geometric::RRTConnect'. Additional configuration parameters will be set when the planner is constructed.
Debug:   The value of parameter 'longest_valid_segment_fraction' is now: '0.01'
Debug:   The value of parameter 'range' is now: '0'
Debug:   manipulator[RRTConnectkConfigDefault]: Planner range detected to be 13.823008
Info:    manipulator[RRTConnectkConfigDefault]: Starting planning with 1 states already in datastructure
Debug:   manipulator[RRTConnectkConfigDefault]: Waiting for goal region samples ...
Debug:   Beginning sampling thread computation
Debug:   Stopped goal sampling thread after 10 sampling attempts
Debug:   manipulator[RRTConnectkConfigDefault]: Waited 0.010097 seconds for the first goal sample.
Info:    manipulator[RRTConnectkConfigDefault]: Created 5 states (2 start + 3 goal)
Info:    Solution found in 0.013512 seconds
Info:    SimpleSetup: Path simplification took 0.005666 seconds and changed from 4 to 2 states

    ================================================================================REQUIRED process [moveit_run_benchmark-3] has died!
process has died [pid 22641, exit code -11, cmd /home/arscontrol/nuovo_ws/devel/lib/moveit_ros_benchmarks/moveit_run_benchmark __name:=moveit_run_benchmark __log:=/home/arscontrol/.ros/log/fdd3e3c8-5e9d-11e8-a63f-d07e3591555f/moveit_run_benchmark-3.log].
log file: /home/arscontrol/.ros/log/fdd3e3c8-5e9d-11e8-a63f-d07e3591555f/moveit_run_benchmark-3*.log
Initiating shutdown!
================================================================================
[moveit_run_benchmark-3] killing on exit
[mongo_wrapper_ros_Kazar_22597_4042277702145717894-2] killing on exit
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

arscontrol@Kazar:~/nuovo_ws$

Has someone faced this issue before or was able to make the benchmarking for his own robot?

My Ubuntu version: 16.04 ROS Kinetic

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-08-01 10:10:22 -0500

updated 2019-08-01 10:13:44 -0500

Well, actually I'm working with this benchmark tool with my ROBOTIS arm (manipulator-h), and discussing with a colleague with think that this error is not an error itself, but simply the code finishing your work (the benchmark) and shutting down. We analyzed different scenarios (queries) in Planner Arena and present differents results. If you find a solution to this or keeped please let know but for know I think that this is normal

edit flag offensive delete link more
0

answered 2018-05-25 06:04:21 -0500

enrico gravatar image

I solved this by installing Moveit from source in the /src folder of my catkin workspace

edit flag offensive delete link more

Comments

Can you show your output for your result? I tried your solution but the actual moveit kinetic version doesn't have the moveit_ros_benchmarks (different from apt-get that contain this package)

kaike_wesley_reis gravatar imagekaike_wesley_reis ( 2019-08-01 10:11:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-05-23 10:54:15 -0500

Seen: 131 times

Last updated: Aug 01