turtlebot nav subscriber.... transform_tolerance does no good [closed]

asked 2018-04-20 11:02:42 -0600

toddwf gravatar image

updated 2018-04-20 11:03:48 -0600

I'm on jade, running the turtlebot and amcl stack for 2dnav. I have a custom launch file which brings together the minimal.launch and amcl and to publish depth-image data so I can use cmvision_3d (which is working in jade).

I have problems with timeouts. When I bring up the launch file below, usually I get few or no warnings and can set goals with rviz with no problem. But when I bring up the cmvision_3d as a subscriber, I immediately get timeouts.

which lead to

So upon reading, I decided to set the transform_timeout to a longer time.

In the turtlebot_navigation/launch/includes/amcl.launch.xml This is set to 1.0 with this note:

This setting seems to be ignored. I tried to modify it and the costmap specifically and it didn't matter. I finally edited the local and global_costmap_params.yaml directly.

Upon testing it, it doesn't work. Or rather, the transform_tolerance is set finally, but the error still occurs. When I start the nav stack, all is well. When I set the cmvision_3d subscriber, I get the same errors. I've tested this all the way up to the unrealistic values of 5.0.

So... Is this a hardware problem?

Or, what else might be happening?

Launch file below.

  <launch>
    <!-- basic turlebot control -->
    <include file="$(find turtlebot_bringup)/launch/minimal.launch">
    </include>

  <!-- kinect and frame ids with data skip param added-->
  <!--   <param name="/camera/driver/data_skip" value="2" /> -->
  <include file="$(find openni_launch)/launch/openni.launch">
    <arg name="depth_registration" value="true"/>
  </include>

  <!-- openni_manager -->
  <node pkg="nodelet" type="nodelet" name="openni_manager" output="screen" respawn="true" args="manager"/>


    <node pkg="depthimage_to_laserscan" type="depthimage_to_laserscan" name="depthimage_to_laserscan" args="image:=/camera/depth_registered/image_raw" respawn="true">
       <!--param name="output_frame_id" value="/camera_depth_frame"/-->
       <param name="scan_height" value="10"/>
        <param name="scan_time" value="0.034"/> <!--was 0.125 -->
        <param name="range_min" value="0.50"/>
        <param name="range_max" value="6.0"/>
        <param name="min_height" value=".10"/>
        <param name="max_height" value="2.0"/>
    </node>


  <!-- Map server -->
  <arg name="map_file" default="/home/todd/research/map.yaml" />
  <node name="map_server" pkg="map_server" type="map_server" args="$(arg map_file)">
    <param name="transform_tolerance" value="0.5"/>
  </node>


  <include file="$(find turtlebot_navigation)/launch/includes/amcl.launch.xml">
    <arg name="initial_pose_x" value="0.6"/>
    <arg name="initial_pose_y" value="0.6"/>
    <arg name="initial_pose_a" value="0.0"/>
    <param name="transform_tolerance" value="0.5"/>
  </include>

  <include file="$(find turtlebot_navigation)/launch/includes/move_base.launch.xml">
    <param name="xy_goal_tolerance" value="0.03"/>
    <param name="yaw_goal_tolerance" value="0.05"/>
  </include>

</launch>

And the cmvision_3d startup is: roslaunch cmvision_3d color_tracker.launch

<launch>
    <arg name="image" default="/camera/rgb/image_color"/>
    <arg name="depth_image" default="/camera/depth_registered/image_raw"/>
    <arg name="camera_topic" default="/camera/rgb/camera_info"/>
    <!-- Do we want to publish our blobs to tf? -->
    <arg name="publish_tf" default="true"/>
  <node name="cmvision" pkg="cmvision" type="cmvision" args="image:=$(arg image)" output="screen">
      <!-- Location of the cmvision color file -->
      <param name="color_file" type="string" 
             value="$(find cmvision_3d)/colors/colors.txt" />

      <!-- Turn debug output on or off -->
      <param name="debug_on" type="bool" value="false ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-09-24 12:24:39.286637