Ask Your Question
0

Simultaneous autonomous navigation and mapping

asked 2018-04-05 17:50:44 -0500

Dox gravatar image

updated 2018-09-07 09:23:13 -0500

If I understood it correctly, in RTABMap ROS tutorials mapping and autonomous navigation is a two step process. First mapping is done by driving robot manually and afterwards autonomous navigation can be accomplished using the previously created map.

Is is possible to make my robot autonomously navigate the unknown environment and simultaneously map the area?

I'm running Ubuntu 16.04.4 LTS on an x86 with ROS Kinetic.

Thank you!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2018-04-06 11:51:02 -0500

matlabbe gravatar image

In the tutorial, the example was to map, then do localization like the official turtlebot navigation tutorial using gmapping/amcl. However, like in the original tutorial, you can still send poses to navigation system (move_base) during the mapping phase. To automatically explore the environment, you would have to integrate an exploration package like frontier_exploration, hector_exploration_planner or explore_lite using the map published by rtabmap and remapping the goals sent by the exploration to move_base.

cheers

edit flag offensive delete link more

Comments

@matlabbe Thanks for a quick response. Besides already mentioned explorers I've found cam_exploration. It is stated that it works along rtabmap_ros package. Is there any particular package that you would recommend using with RTABMap?

Dox gravatar imageDox ( 2018-04-06 16:35:10 -0500 )edit
1

Thx to link cam_exploration. If an exploration package is dependent of TF and a 2d occupancy grid map, then it is compatible with rtabmap and many other slam packages. I have limited experience myself with these exploration packages, so I cannot tell which is the best.

matlabbe gravatar imagematlabbe ( 2018-04-06 16:56:33 -0500 )edit

Today I tried to publish 2D nav goal in rviz but got this

[ERROR] [1523105102.467464668]: Cannot connect to move_base action server!

RTABMap did start successfully. I'm testing with this launch file.I also consulted this. Any thoughts?

Dox gravatar imageDox ( 2018-04-07 15:20:08 -0500 )edit
1

Make sure the properties of the 2D nav goal button in RVIZ is set to correct goal topic of move_base. See http://wiki.ros.org/navigation/Tutori... , looks like in your launch file that the goal topic would be /planner/move_base_simple/goal

matlabbe gravatar imagematlabbe ( 2018-04-09 09:32:55 -0500 )edit

Great, I did manage to do it, and also with the help of this now I can see:

Planning: Path successfully created (size=1)

but robot still wouldn't move. Could it be that remapping from /planner/cmd_vel to rosaria/cmd_vel is needed? I'm not able to test it atm...

Dox gravatar imageDox ( 2018-04-09 15:58:12 -0500 )edit
1

Yes, you should remap cmd_vel from move_base to rosaria's cmd_vel. You can do rostopic echo /planner/cmd_vel to see if move_base is actually sending commands

matlabbe gravatar imagematlabbe ( 2018-04-10 10:48:07 -0500 )edit

Tnx! Finally, the robot is navigating! :) If I would like to do it remotely, do you know if move_base can also be remotely run with rtabmap?

Dox gravatar imageDox ( 2018-04-10 14:03:03 -0500 )edit

Yes, http://wiki.ros.org/rtabmap_ros/Tutor... , though you will have network latency issues. At least keeping move_base on the robot would be more safe.

matlabbe gravatar imagematlabbe ( 2018-04-10 14:40:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2018-04-05 17:50:44 -0500

Seen: 1,928 times

Last updated: Sep 07 '18