Ask Your Question
0

ros_vrpn_client installation help

asked 2018-03-19 12:30:54 -0500

oha gravatar image

Hi all, I want to install ros_vrpn_client but can't find any good instructions for it. I spcifically can't find references to kinetic or Ubuntu 16.04 when I search for ros_vpn_client, but I am running under the the hope that it will work for it, as I see no other options.

The ROS page says to just run install_vrpn.sh. The problem is it doesn't give a direct link to the package. I downloaded vrpn from:
https://github.com/vrpn/vrpn/releases but that doesn't have the install_vrpn.sh file in it. No repository I found has this file. In the installation page I got from the wiki it says to just cmake it, but cmake requires options and I don't know what it wants. The closest I got was this forum post:
https://answers.ros.org/question/5425...
but he didn't have enough karma to give the link and using svn co https://github.com/gt-ros-pkg doesn't download anything.

I also tried what is mentioned in this forum post:
https://answers.ros.org/question/2647...
But ran into catkin_make issues aswell

I also tried installing mocap_optitrack instead, but it says to just use apt-get, except apt-get doesn't find the repository they specify, and they didn't say to add a ppa or something.

I know that I am a beginner, but for the life of me I can't understand why it is so hard to find normal installation instructions for this that even a beginner can understand. I appreciate all the work people have put into this, and make it opensource and free for use, but I have been trying to just install it for several hours now, and can't find the most basic like an install file or other instructions.

Any help will be greatly appreciated!

edit retag flag offensive close merge delete

Comments

1

It is always a good idea to include links to the packages that you are referring to. In this case I believe your're trying to install ros_vrpn_client, correct?

As you can see at the top of that page, it was only ever 'released' for ROS Fuerte, ..

gvdhoorn gravatar imagegvdhoorn ( 2018-03-19 14:06:15 -0500 )edit

.. which is an EOL version of ROS that is already almost 7 to 8 years old. There is a chance it can work on newer, more recent, versions, but if you're just starting out, that may not be trivial to achieve.

The VRPN repository did see development over the years, so some bitrot and ..

gvdhoorn gravatar imagegvdhoorn ( 2018-03-19 14:07:47 -0500 )edit

.. references to files that you can no longer find would not seem to be unexpected.

If you were instead referring to ros-drivers/vrpn_client_ros, that does seem to have been kept up-to-date and should work under ROS Kinetic.

gvdhoorn gravatar imagegvdhoorn ( 2018-03-19 14:09:08 -0500 )edit

Thanks you so much for your response! I should have linked to that page, my mistake. I realize it hasn't been updated, but as I said I didn't see other options. I did try ros-drivers/vrpn_client_ros, but there is no explanation on how to install it, so I followed what was written in...

oha gravatar imageoha ( 2018-03-20 00:47:59 -0500 )edit

... https://answers.ros.org/question/2647... and reached problems with catkin_make - I am sure I am doing something wrong here. Basically I just cloned the repo into my ~/catkin_ws/src folder and tried to catkin_make and it gave problems. I will rerun this again in an hour...

oha gravatar imageoha ( 2018-03-20 00:50:26 -0500 )edit

... and post exactly what the issue was exactly (I am not near that pc now). I honestly mostly disregarded that repo cause it seemed very empty relative to the original repo so I was sure it relied on me having the other, original, repo working prior to using it. Thanks again for the help!

oha gravatar imageoha ( 2018-03-20 00:53:46 -0500 )edit

Ok, so in order to fix my catkin_make issue I needed to run sudo apt-get update and rosdep install --from-paths . from inside the repository i cloned. I will now figure out how to get it to transfer the data and post a full answer of what I did. I got this answer from forum post 227267.

oha gravatar imageoha ( 2018-03-20 01:49:43 -0500 )edit

As the author of the answer in #q227267 already asks: do you have a specific reason for wanting to build all of this from sources? If you don't, then seeing as vrpn_client_ros has been released into Kinetic, you should probably not clone the sources and install dependencies. The following ..

gvdhoorn gravatar imagegvdhoorn ( 2018-03-20 02:43:12 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-25 10:43:31 -0500

oha gravatar image

updated 2018-03-27 05:37:06 -0500

Ok, so I have it working and this is what I did:

I ended up using vrpn_ros_cliet (not to be confused with ros_vrpn_client):
http://wiki.ros.org/vrpn_client_ros

  • Install vrpn_client_ros:

    • gvdhoorn mentioned you can easily do this with:
      sudo apt-get install ros-kinetic-vrpn-client-ros
    • I didn't do it that way, because I found an explanation on the following before I knew of that option, so I can't vouch for it working, what I did do is:
      • Go to catkin src folder: cd ~/catkin_ws/src
      • clone the repository: git clone https://github.com/ros-drivers/vrpn_client_ros.git
      • update my repos before installing dependencies: sudo apt-get update
      • go to cloned reposetory and install dependencies using: rosdep install --from-paths .
      • go to catkin home directory (may differ if you made it differently): cd ~/catkin_ws
      • make catkin: catkin_make
  • launch vrpn_client_ros:
    roslaunch vrpn_client_ros sample.launch server:=<ip_of_server_machine>

    • you should see a "connection established" line at the end
  • you can check if the node is running using rosnode list
  • If you already set up motive with the streaming configurations and you have a rigid body marked in your world you can see if the data is passed to ros using:
    rostopic echo /vrpn_client_node/<name_of_rigid_body>/pose

  • Configuring Motive:

    • streaming data:

      • Basically I followed instructions in http://wiki.ros.org/mocap_optitrack (even though they reference an old version of motive) but I will explain what I did anyways.
      • In motive go to the streaming pane (icon looks like radio signal)
      • press on the three dots at the top and "Show Advance"
      • not sure if this is relavent, but "local interface" is on "loopback"
      • make sure "Rigid Bodies" is on
      • set "Transmission Type" to "Multicast"
      • set "Multicast Interface" to your ros machines IP address
      • set "Broadcast VRPN Data" to on
      • "VRPN Broadcast Port" should stay 3883
    • calibrate cameras:
      I followed this video: https://www.youtube.com/watch?time_co...

    • creating rigid body:
      I followed the instructions in https://v20.wiki.optitrack.com/index....

I hope this manages to help someone else, it was very frustrating for me, but seeing it now it seems fairly simple.
A lot of thanks to all the people who helped me along the way, especially gvdhoorn who answered my questions quick and graciously.

edit flag offensive delete link more

Comments

I didn't do it that way so I can't vouch for it working, what I did do is

this answer would be even better if you can clarify why you didn't install the binary packages, but built things from source yourself.

gvdhoorn gravatar imagegvdhoorn ( 2018-03-25 11:18:42 -0500 )edit

you are right, I added in that it was basically because I found an explanation to build the binaries before I found a place saying how to do it the way you proposed, which is simpler. If I would have found the easy way first I would have used it.

oha gravatar imageoha ( 2018-03-25 11:44:48 -0500 )edit

Just wondering does the pos in vrpn_client_node include attitude information or is it only the x, y, z coordinates? I found out that it does give attitude data as well in quaternion. However can it also give the rate data or velocity data?

haloted gravatar imagehaloted ( 2019-10-12 07:24:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-19 12:30:54 -0500

Seen: 1,663 times

Last updated: Mar 27 '18