hokuyo UTM-30LX-EW cannot open network

asked 2018-02-18 03:16:17 -0600

nikfio gravatar image

Hello everyone,

I'm working with the Hokuyo UTM-30LX-EW connected to the raspberri pi 3 model B, raspberry is connected through wlan0 interface with ip 192.168.10.14, meanwhile the ip of the hokuyo is the default 192.168.0.10. Now I can ping the hokuyo with raspberry, but when I run:

      rosrun urg_node urg_node _ip_address:=192.168.0.10

it gives out:

Error connecting to Hokuyo: Could not open network Hokuyo: 192.168.0.10:10940 Could not open ethernet port

Even if I run roscore on raspberry without any connection, still the same error message.

An alternative would be assigning to hokuyo an ip of the same wireless network, so I try to run

    Connecting to 192.168.0.10
     Traceback (most recent call last):
      File "/home/nikfio/bin/ros-roomba-pkgs/src/urg_node/scripts/set_urg_ip.py", line 72, in <module>
      sock.connect((args.ip, 10940))
      File "/usr/lib/python2.7/socket.py", line 228, in meth
     return getattr(self._sock,name)(*args)
    socket.error: [Errno 111] Connection refused

I get this error lines, so not possible this way. If you have any suggestion or ideas I wouls really appreciate it, everthing else works smoothly, this one is the last missing.

Thank you.

edit retag flag offensive close merge delete