Ask Your Question
1

catkin_make: catkin_pkg.package not found (anaconda)

asked 2018-02-02 02:08:34 -0500

Nebula gravatar image

updated 2018-02-02 04:18:35 -0500

gvdhoorn gravatar image

I am unable to solve this problem. I tried to run catkin_make command in catkin_ws directory.

yograj@yograj-Inspiron-5537:~/catkin_ws$ catkin_make
Base path: /home/yograj/catkin_ws
Source space: /home/yograj/catkin_ws/src
Build space: /home/yograj/catkin_ws/build
Devel space: /home/yograj/catkin_ws/devel
Install space: /home/yograj/catkin_ws/install
####
#### Running command: "cmake /home/yograj/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/yograj/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/yograj/catkin_ws/install -G Unix Makefiles" in "/home/yograj/catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/yograj/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/kinetic
-- This workspace overlays: /opt/ros/kinetic
-- Using PYTHON_EXECUTABLE: /home/yograj/anaconda2/bin/python
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/yograj/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
ImportError: "from catkin_pkg.package import parse_package" failed: No module named catkin_pkg.package
Make sure that you have installed "catkin_pkg", it is up to date and on the PYTHONPATH.
CMake Error at /opt/ros/kinetic/share/catkin/cmake/safe_execute_process.cmake:11 (message):
  execute_process(/home/yograj/anaconda2/bin/python
  "/opt/ros/kinetic/share/catkin/cmake/parse_package_xml.py"
  "/opt/ros/kinetic/share/catkin/cmake/../package.xml"
  "/home/yograj/catkin_ws/build/catkin/catkin_generated/version/package.cmake")
  returned error code 1
Call Stack (most recent call first):
  /opt/ros/kinetic/share/catkin/cmake/catkin_package_xml.cmake:74 (safe_execute_process)
  /opt/ros/kinetic/share/catkin/cmake/all.cmake:151 (_catkin_package_xml)
  /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:20 (include)
  CMakeLists.txt:52 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/yograj/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/yograj/catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-02-02 11:34:03 -0500

Nebula gravatar image

I solved by following similar problem.

with using

pip install -U rosdep rosinstall_generator wstool rosinstall six vcstools
edit flag offensive delete link more
0

answered 2018-02-02 02:52:00 -0500

jayess gravatar image

From @tfoote's answer for a very similar question:

to use Anaconda you will need to do a lot with your PYTHONPATH to make sure that all dependencies are on the path that Anaconda's interpreter is using.

I would recommend trying to find a way to use anaconda separately/in parallel with your anaconda installation. The main problem is that Anaconda doesn't use the standard installed python libraries so often you end up with missing resources.

edit flag offensive delete link more

Comments

I solved by following similar problem.

with using

pip install -U rosdep rosinstall_generator wstool rosinstall six vcstools
Nebula gravatar imageNebula ( 2018-02-02 07:09:20 -0500 )edit

Great, but please don't use a comment to provide an answer, that's what answers are for.

jayess gravatar imagejayess ( 2018-02-02 10:13:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-02-02 02:08:34 -0500

Seen: 697 times

Last updated: Feb 02 '18