Ask Your Question
0

Unknown CMake command "catkin_project"

asked 2012-08-26 16:42:22 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Ubuntu 12.04 and Fuerte

I have downloaded the cyphy stack from ROS repositories.

Installed all the required dependencies

sai@sai:~/fuerte_workspace$ rosdep install cyphy_xsens_mtig
#All required rosdeps installed successfully

then when i did ROSMAKE

sai@sai:~/fuerte_workspace$ rosmake cyphy_xsens_mtig 



{-------------------------------------------------------------------------------
  mkdir -p bin
  cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=`rospack find rosbuild`/rostoolchain.cmake  ..
  CMake Error at CMakeLists.txt:3 (catkin_project):
    Unknown CMake command "catkin_project".


  CMake Warning (dev) in CMakeLists.txt:
    No cmake_minimum_required command is present.  A line of code such as

      cmake_minimum_required(VERSION 2.8)

    should be added at the top of the file.  The version specified may be lower
    if you wish to support older CMake versions for this project.  For more
    information run "cmake --help-policy CMP0000".
  This warning is for project developers.  Use -Wno-dev to suppress it.

  -- Configuring incomplete, errors occurred!
-------------------------------------------------------------------------------}

This is the error..

Please let me know how this issue can be solved.

Thanks

edit retag flag offensive close merge delete

Comments

I resolved the issue by changing the ROS_PACKAGE_PATH variable. i gave the priority to the packages downloaded during installation than the packages downloaded from repository. Finally it worked..I mean i was able to ROSMAKE but when i do ROSRUN..I m not getting the output..Unable to connect to Mti.

sai gravatar imagesai ( 2012-08-26 23:41:15 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-08-26 23:13:01 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I guess the project you are trying to compile already use the new ROS build system catkin. You cannot build that with rosmake. You can find some documentation here.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-08-26 16:42:22 -0600

Seen: 908 times

Last updated: Aug 27 '12