Ask Your Question
0

Issues with prosilica camera connected through router

asked 2018-01-19 14:34:31 -0500

JKaiser gravatar image

updated 2018-01-19 22:15:58 -0500

I'm testing a Prosilica GT1290C camera with a Pioneer 3AT robot, connected through a router to it. The robot has Ubuntu 14.04 with ROS Indigo and all the packages needed to operate the camera installed. After creating the workspace and the launch file to run the camera, I run the file. Up to this point there are no apparent issues, save for two warnings:

[ WARN] [1516390051.841257070]: Detected max data rate is 12400000 bytes/s, typical maximum data rate for GigE port is 115000000 bytes/s. Are you using a GigE network card and cable?

and

[ WARN] [1516390055.911854963]: Reconfigure callback failed with exception Couldn't set horizontal binning: Attribute value is out of the expected range:

Then I try to see the images with image_view, but all I get is a blank screen:

image description

yet with Vimba Viewer it works fine:

image description

Then, I tried connecting the camera directly in the robot and run the exact same launch file (no changes at all) and this happens:

image description

No warnings and image_view can show the images without issue.

Note that the nodes used were those provided with the package prosilica_camera. Any idea why does that happen or what is causing it?

The launch file:

<!--
Starts a PR2 Prosilica camera in streaming mode.
This file exists mainly for backwards compatibility.
-->
<launch>
   <node name="prosilica_driver" pkg="prosilica_camera" type="prosilica_node" output="screen">
      <param name="ip_address" type="str" value="192.168.3.103"/>
      <param name="trigger_mode" type="str" value="streaming"/>
      <remap from="camera" to="prosilica" />
   </node>
</launch>
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-02-07 14:04:57 -0500

JKaiser gravatar image

I managed to fix it by changing the number in every instance of the line

camera_->setAttribute("StreamBytesPerSecond", (tPvUint32)(115000000/num_cameras));

in prosilica_nodelet.cpp to the smaller number indicated in the ROS warning (115000000 to 12400000).

edit flag offensive delete link more

Comments

Wouldn't that be more of a work-around?

gvdhoorn gravatar imagegvdhoorn ( 2018-02-08 01:33:31 -0500 )edit
1

I think so too, but I believe a true solution isn't within ROS. The router provided does not support Jumbo Packets.

JKaiser gravatar imageJKaiser ( 2018-02-08 09:49:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-01-19 14:34:31 -0500

Seen: 120 times

Last updated: Feb 07 '18