Ask Your Question
0

Invoking "make -j1 -l1" failed

asked 2018-01-18 08:49:06 -0500

nickapril gravatar image

Trying to set up a ROS environment in Ubuntu with the instructions here:

http://emanual.robotis.com/docs/en/pl...

I run into an error at step 5.2.1 after the last command below.

$ sudo apt-get update
$ sudo apt-get upgrade
$ wget https://raw.githubusercontent.com/ROBOTIS-GIT/robotis_tools/master/install_ros_kinetic.sh && chmod 755 ./install_ros_kinetic.sh && bash ./install_ros_kinetic.sh

error: ‘const struct turtlebot3_msgs::SensorState_<std::allocator<void>’ has no member named ‘torque’
if (msg->torque == true) ^ turtlebot3/turtlebot3_bringup/CMakeFiles/turtlebot3_diagnostics.dir/build.make:62: recipe for target 'turtlebot3/turtlebot3_bringup/CMakeFiles/turtlebot3_diagnostics.dir/src/turtlebot3_diagnostics.cpp.o' failed make[2]: ** [turtlebot3/turtlebot3_bringup/CMakeFiles/turtlebot3_diagnostics.dir/src/turtlebot3_diagnostics.cpp.o] Error 1 CMakeFiles/Makefile2:1892: recipe for target 'turtlebot3/turtlebot3_bringup/CMakeFiles/turtlebot3_diagnostics.dir/all' failed make[1]: ** [turtlebot3/turtlebot3_bringup/CMakeFiles/turtlebot3_diagnostics.dir/all] Error 2 Makefile:138: recipe for target 'all' failed make: *** [all] Error 2 Invoking "make -j1 -l1" failed

Any thoughts on what may be causing this? I get the same error if I try to run catkin_make after following the emanual robotics instructions as well.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2018-03-02 07:10:22 -0500

cardboardros gravatar image

I have encountered a similar problem with the same error output:

error: ‘const struct turtlebot3_msgs::SensorState_<std::allocator<void>’ has no member named ‘torque’ if (msg->torque == true) ^

Explaination: There is no current message that has the format turtlebot3_msgs::SensorState which can be found in your catkin_ws workspace.

Steps To Rectify:

1. Follow the steps after where you left off at step 5.2.1 (Here's the link again.Click Here)

2. Under 6.3 Install Independent Packages, ensure that you are in your catkin_ws/src and run the following command according to the emanual.

$ git clone https://github.com/ROBOTIS-GIT/turtlebot3_msgs.git

This is where the turtlebot3_msgs::SensorState message is located.

3. Return back to the root of your catkin_ws by running $ cd ~/catkin_ws

4. run $ source devel/setup.bash

5. run $ catkin_make

It worked for me. Hopes it works for you as well.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-01-18 08:49:06 -0500

Seen: 508 times

Last updated: Jan 18 '18