Ask Your Question
0

robot_upstart: Nothing starts on startup

asked 2018-01-09 13:49:06 -0500

mohsen gravatar image

updated 2018-01-10 02:41:17 -0500

I have successfully executed the command

rosrun robot_upstart install myPackage/test.launch

and also

sudo systemctl daemon-reload && systemctl start myPackage

But after I reboot or restart, I can confirm by using rosnode list and rostopic list that the nodes listed in the launch file never start. Starting the launch file using roslaunch works fine so that's not the issue.
Here's the content of test.launch

<launch>
      <node name='node' pkg='myPackgage' type='simple_node' />
      <node name='graph' pkg='rqt_graph' type='rqt_graph' />
</launch>

Update 1: Additional information:
- Starting the service manually doesn't work (even before reboot).

sudo service myPackage start

No error, but nodes don't run.
- Files installed during the robot_upstart install process are still there after reboot.
- There is no log file for robot_upstart in /var/log/
- There's only one user account, and logging into it I can see the packages and environment variables.

Update 2:
I tried launching a couple other nodes and they worked fine. But that one node which receives sensor data still doesn't run. (rqt_graph doesn't run either, but it doesn't matter since it's useless as a daemon.)

edit retag flag offensive close merge delete

Comments

I asked a new, more specific question about the nodes that don't launch.

mohsen gravatar image mohsen  ( 2018-01-10 07:35:49 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-01-09 14:09:36 -0500

130s gravatar image

updated 2018-01-10 09:10:06 -0500

Not an answer yet, but I share some things to look at installation issue with robot_upstart (not limited to these):

  • Does the service have an access to the following? Log on as the user account (i.e. usually root for upstart) that runs the service process and see:
    • the ROS packages you defined in the launch file you passed to the install script?
    • ROS-related environment variables e.g. ROS_PACKAGE_PATH?
  • For a list of resources the install script shows at the end of its run, do you still see them at each location after reboot?
  • Do you see your application's log under /var/log/upstart/? If so do you see any errors.
edit flag offensive delete link more

Comments

Thanks. I updated the question.

mohsen gravatar image mohsen  ( 2018-01-09 14:57:13 -0500 )edit
1

I updated slightly; You need to log in as a root to see env vars etc., unless you specifically configure your upstart to use another account.

130s gravatar image 130s  ( 2018-01-10 09:11:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2018-01-09 13:49:06 -0500

Seen: 1,142 times

Last updated: Jan 10 '18