Ask Your Question
2

problem in Moveit Tutorials step: MoveGroup interface Tutorial

asked 2018-01-05 02:29:19 -0600

七小丘人 gravatar image

updated 2018-01-05 02:36:42 -0600

jayess gravatar image

My distro of ROS is kinetic. I followed the lastest moveit tutorial:

http://docs.ros.org/kinetic/api/movei...

When I run the command

 roslaunch moveit_tutorials move_group_interface_tutorial.launch

I meet the error

process[move_group_interface_tutorial-1]: started with pid [5502]
/home/qiuyilin/ROSSP/ws_moveit/devel/lib/moveit_tutorials/move_group_interface_tutorial: error while loading shared libraries: libmoveit_planning_scene_monitor.so.0.9.11: cannot open shared object file: No such file or directory
[move_group_interface_tutorial-1] process has died [pid 5502, exit code 127, cmd /home/qiuyilin/ROSSP/ws_moveit/devel/lib/moveit_tutorials/move_group_interface_tutorial __name:=move_group_interface_tutorial __log:=/home/qiuyilin/.ros/log/1c468b9c-f1ef-11e7-afc5-0028f8fda2a0/move_group_interface_tutorial-1.log].

and when I run

catkin config --extend /opt/ros/kinetic --cmake-args -DCMAKE_BUILD_TYPE=Release

it shows my log space is missing.

edit retag flag offensive close merge delete

Comments

I get the same crash in the indigo version.

Juan gravatar image Juan  ( 2018-01-08 02:21:29 -0600 )edit

Got the same me too with kinetic !

Ahrimanox gravatar image Ahrimanox  ( 2018-01-22 10:02:12 -0600 )edit

==I just forgot the problem and it worked after some time. Now the tutorial of moveit! also has changed.

七小丘人 gravatar image 七小丘人  ( 2019-02-26 20:57:37 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-10-31 14:40:39 -0600

130s gravatar image

updated 2018-10-31 16:16:49 -0600

I'm sure I'm wrong about details but hopefully I got the main idea correct. @v4hn can correct me if needed.

Direct cause and potential solution

What the cited error means I think is that the mentioned .so file was sought but not found. Assuming you have MoveIt! installed by binary (e.g. via apt-get install on Ubuntu), you can check if those files are available by e.g. find /opt/ros -iname libmoveit*.

  • If they can't be found, install MoveIt!.
  • If they are there but different version number, update those libraries (e.g. on Ubuntu, apt-get dist-upgrade / apt-get install --reinstall ros-%DISTRO%-moveit).

Rationale

Binary of MoveIt! uses SONAME in order to guarantee the ABI in/compatibility between releases and provide more organized way of debugging problems that are bsed on ABI breakage (*1). As a result, applications of the library in MoveIt! need to be rebuilt whenever MoveIt! library was updated.

*1 FYI for the decison in MoveIt! to introduce SONAME, see ros-planning/moveit#273.

(Maybe) A bit more advanced error situation

The following may or may not be the case of OP, but I just experienced in my application.

The same type of error can happen in the following situation (I use MoveIt! here but it could be any library that uses SONAME solution):

  • On your local computer, MoveIt! remains old version, although new releases are available.
  • Your application depends on another library (say libA) that depends on MoveIt!, and libA on your computer is already re-built against the latest released MoveIt!.
  • Build your application.

I'm quite not sure how catkin and linker work, but what I see is linker tries to find the latest version of MoveIt! libs. I assume linker somehow got the version info from libA (in my case this was moveit_visual_tools, which got installed via rosdep install right before running catkin build).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2018-01-05 02:29:19 -0600

Seen: 972 times

Last updated: Feb 26 '19