Ask Your Question
0

Can't locate node ardrone_driver node in ardrone_autonomy package.

asked 2017-12-26 17:24:57 -0600

malharjajoo gravatar image

updated 2017-12-27 12:54:43 -0600

Although this has been asked here before, there was no solution.

Background: I am using a real-drone ( not ROS simulation ) I have been trying to follow this tutorial ( I'm not using a VM ) for which I need to install the ardrone_autonomy package by -

  1. installing binary directly using sudo apt-get install ros-kinetic-ardrone-autonomy .

  2. Cloning source from github ( git clone https://github.com/tum-vision/ardrone_autonomy.git ) and then ./build_sdk.sh didn't build due to some errors.

    Since method 2) didn't build, after I used method 1) and ran the command (roslaunch ardrone_tutorials keyboard_controller_outdoor.launch) from the tutorial I got the following error -

    ERROR: cannot launch node of type [ardrone_autonomy/ardrone_driver]: can't locate node [ardrone_driver] in package [ardrone_autonomy]

The issue: I can't seem to find the ardrone_driver file anywhere. ( I tried using linux find ). There are other few other errors too (unrelated hence not shown above, just mentioning for completeness).

System specs: Ubuntu Xenial and ROS kinetic.

Please help.

Thanks!

Update:

rospack find ardrone_autonomy gives /home/malhar/catkin_ws/src/ardrone_autonomy

edit retag flag offensive close merge delete

Comments

Did you install the ardrone_autonomy package? That tutorial (which is quite old!) uses the ardrone_autonomy package to connect with the drone. Also, do you have the actual drone or are you using a simulator?

jayess gravatar imagejayess ( 2017-12-26 17:48:29 -0600 )edit

Thanks for replying @jayess , yes I used apt-get to install ardrone_autonomy ( I have also updated the question )

malharjajoo gravatar imagemalharjajoo ( 2017-12-26 19:06:10 -0600 )edit

Where did you search for it? Please update your question with the result of rospack find ardrone_autonomy.

jayess gravatar imagejayess ( 2017-12-26 20:04:41 -0600 )edit

Are you sourcing your setup.bash?

jayess gravatar imagejayess ( 2017-12-27 11:20:41 -0600 )edit

rospack find ardrone_autonomy gives the correct file path (/home/malhar/catkin_ws/src/ardrone_autonomy ) to the package folder.

I'm not certain why you want me to find the ardrone_autonomy package. As mentioned in the question, I am unable to find the ardrone_driver node,

malharjajoo gravatar imagemalharjajoo ( 2017-12-27 11:22:29 -0600 )edit

That location is actually not the correct directory if you used apt to install the package. It should be in your /opt/ros/kinetic/share directory. If you plan on using the apt installed version. Try deleting this one, recompile, and source your setup.bash.

jayess gravatar imagejayess ( 2017-12-27 11:50:06 -0600 )edit

Ok thanks, I understand. I removed the github source installations from my catkin_ws. However, now rospack cannot find the ardrone_autonomy package.

Do I have to be connected to the drone wifi for rospack to be able to find ardrone_autonomy ? ( I don't think so but would like to confirm )

malharjajoo gravatar imagemalharjajoo ( 2017-12-27 12:49:42 -0600 )edit

If you haven't already, delete the ~/catkin_ws/build and ~/catkin_ws/devel directories and rebuild using catkin_make or whatever build tool you're using.

clyde gravatar imageclyde ( 2017-12-27 14:21:02 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-12-27 15:19:24 -0600

jayess gravatar image

updated 2017-12-27 18:43:45 -0600

You still have the package that you downloaded from GitHub in your workspace which is why when you run rospack find ardrone_autonomy you see that it's located in ~/catkin_ws/src/ardrone_autonomy.

Follow these steps:

  1. Delete this package along with the ~/catkin_ws/build, ~/catkin_ws/devel, and ~/catkin_ws/install directories (as noted by @clyde )
  2. Compile your workspace again.
  3. Now, source (ROS if you're not doing that already and) your workspace:

    $ source /opt/ros/<distro>/setup.bash
    $ source ~/catkin_ws/devel/setup.bash
    
  4. Run

    $ roslaunch ardrone_tutorials keyboard_controller_outdoor.launch
    

    again and roslaunch should be able to find the ardrone_driver node. Note that to find and launch the node you don't have to be connected to your drone. But, to use it you do need to be connected to the drone.

Please update your question if this still doesn't fix your issue.

Note: I've moved the question's comments into this answer.

edit flag offensive delete link more

Comments

If this answer solved your problem, please click on the checkmark to mark the answer as correct.

jayess gravatar imagejayess ( 2018-01-10 16:09:53 -0600 )edit

Hi, sorry for the delay... I will quickly get back to this in a day.

malharjajoo gravatar imagemalharjajoo ( 2018-01-11 03:11:18 -0600 )edit

@malharjajoo: if this solved your problem please click on the check mark to mark it as the correct answer.

jayess gravatar imagejayess ( 2018-01-31 22:58:40 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-26 17:20:41 -0600

Seen: 315 times

Last updated: Dec 27 '17