Teleop isn't moving Gopigo2 robot [closed]

asked 2017-12-23 18:55:29 -0500

Noidea gravatar image

updated 2017-12-24 15:55:58 -0500

jayess gravatar image

Gopigo2 Rpi2B - Linux raspberrypi 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)" NAME="Raspbian GNU/Linux" VERSION_ID="8" VERSION="8 (jessie)" ID=raspbian ID_LIKE=debian

When I run teleop_twist_keyboard and try to initiate a command on my gopigo nothing happens. You can see the messages change as shown below but no change on the gopigo/ropigo. The topics are displaying on the remote PC(not ssh). Any idea what I should look at first? Thanks in advance.

ubuntu@ubuntu:~$ rostopic echo /cmd_vel
linear: 
  x: 0.0
  y: 0.0
  z: 0.0
angular: 
  x: 0.0
  y: 0.0
  z: 0.0
---
linear: 
  x: 0.55
  y: 0.0
  z: 0.0
angular: 
  x: 0.0
  y: 0.0
  z: 1.1

ubuntu@ubuntu:~/catkin_ws$ rostopic list
/battery
/cmd_vel
/lwheel
/rosout
/rosout_agg
/rwheel
/servo_cmd
/servo_state
/ultrasonic

pi@raspberrypi:~/gopigo_ws $ rosrun ropigo ropigo_node
[ INFO] [1514071469.689818951]: GoPiGo Firmware Version: 16
[ INFO] [1514071469.690366452]: GoPiGo Board Version: 14

pi@raspberrypi:~/Dexter/GoPiGo/Troubleshooting $ roswtf
No package or stack in context
================================================================================
Static checks summary:

No errors or warnings
================================================================================
Beginning tests of your ROS graph. These may take awhile...
analyzing graph...
... done analyzing graph
running graph rules...
... done running graph rules

Online checks summary:

Found 1 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING The following node subscriptions are unconnected:
 * /ropigo:
   * /servo_cmd


=============================
GoPiGo Troubleshooting Script
=============================

Adding permissions to the scripts
=================================

Check space left
================
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        30G  8.0G   21G  29% /
devtmpfs        458M     0  458M   0% /dev
tmpfs           462M     0  462M   0% /dev/shm
tmpfs           462M  6.3M  456M   2% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           462M     0  462M   0% /sys/fs/cgroup
/dev/mmcblk0p1   42M   21M   21M  51% /boot
tmpfs            93M     0   93M   0% /run/user/1000

Check for dependencies
======================
python 2.7.9-1 install ok installed
python-pip 1.5.6-5 install ok installed
git 1:2.1.4-2.1+deb8u5 install ok installed
libi2c-dev 3.1.1+svn-2 install ok installed
python-serial 2.6-1.1 install ok installed
python-rpi.gpio 0.6.3~jessie-1 install ok installed
i2c-tools 3.1.1+svn-2 install ok installed
python-smbus 3.1.1+svn-2 install ok installed
arduino 2:1.0.5+dfsg2-4 install ok installed
minicom 2.7-1+deb8u1 install ok installed
scratch 1.4.0.6~dfsg1-5 install ok installed

wiringPi Found
wiringPi Found
I2C still in blacklist (ERR)
SPI still in blacklist (ERR)


Check for addition in /modules
==============================
I2C-dev already there
i2c-bcm2708 already there
spi-dev already there


Hardware revision
=================
gpio version: 2.36
Copyright (c) 2012-2015 Gordon Henderson
This is free software with ABSOLUTELY NO WARRANTY.
For details type: gpio -warranty

Raspberry Pi Details:
  Type: Pi 2, Revision: 01, Memory: 1024MB, Maker: Embest 
  * Device tree is enabled.
  *--> Raspberry Pi 2 Model B Rev 1.1
  * This Raspberry Pi supports user-level GPIO access.


Check the /dev folder
=====================
i2c-1
ttyAMA0

USB ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Noidea
close date 2017-12-27 20:57:52.761493

Comments

Tip: state the problem in the title. E.g., "Teleop isn't moving Gopigo2 robot."

clyde gravatar imageclyde ( 2017-12-24 12:17:11 -0500 )edit

Looks like https://github.com/ros-gopigo/ros-nod... has lots of DEBUG messages. You can use these to make sure that the node is receiving and responding to the message. See http://wiki.ros.org/rosconsole#Config... for logging configuration.

clyde gravatar imageclyde ( 2017-12-24 12:18:57 -0500 )edit

Thanks clyde I added to my post the output from turning on a LED but the LED doesnt light.

Noidea gravatar imageNoidea ( 2017-12-24 14:22:38 -0500 )edit

Does it work if you run teleop_twist_keyboard on the raspberry PI over SSH? If it does, it could indicate a network issue.

ahendrix gravatar imageahendrix ( 2017-12-26 22:07:25 -0500 )edit

Hi ahendrix, I tried enabling a LED through the service directly on the robot and it says it enable and returns no errors but the LED never comes on. When I initial the cpp file with rosrun the LED's light as they should but for some reason the service is no initiating the enable command.

Noidea gravatar imageNoidea ( 2017-12-27 12:09:56 -0500 )edit