Install issues on Ubilinux v4 (dolcetto)

asked 2017-12-05 18:17:54 -0500

Corusco gravatar image

Greetings all,

I'm having trouble installing ROS kinetic on the new release of Ubilinux. I had it successfully running on ver 3, but a file system corruption prompted me to try the upgrade.

I've tried the (my) standard method of installing using apt after setting up the sources.list.d/ubilinux-dolcetto.list sources list to bring in the debian jessie lists. The key I'm using for the keyserver is the one beginning with 412. Updating apt seems to source everything without incident. When doing the apt-get install ros-kinetic-whatever, I get an error indicating unmet dependencies, even for packages I've installed individually. Other packages unrelated to ROS install without incident using apt.

I then tried the python method of installing everything with pip, including rosdep, and then running rosdep update, but I get an error indicating the script can't detect the OS, and I'm not sure where to start hunting to figure out what the script is looking at to determine the OS to make needed fixes.

I'd love to hear any guidance; I'd really love to hear about successful installations with the new version of Ubilinux.

Thanks as always!

edit retag flag offensive close merge delete