Ask Your Question
1

No /opt/ros

asked 2012-04-22 11:01:26 -0500

sterlingm gravatar image

updated 2014-01-28 17:12:02 -0500

ngrennan gravatar image

I am using Debian 10.6.4. I have done all of the steps here http://www.ros.org/wiki/electric/Installation/Debian up for installation and am now at the first tutorial. I get to creating the setup.sh file in the workspace, but I have no /opt/ros! When should this have been created?

rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=electric&variant=desktop-full&overlay=no"

Did something go wrong in this step? Or the source ~/ros/setup.bashrc? Any help would be great.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-04-22 11:29:39 -0500

Eric Perko gravatar image

A source install like you did with rosinstall does not necessarily install anything to /opt/ros . /opt/ros is where the binary packages (.debs built for Ubuntu) install to.

Based on your rosinstall line, you should be able to find the setup.bash file in ~/ros. Note that you likely won't have the electric directory either, so the ROS_ROOT variable in those tutorials is not correct for your installation either.

edit flag offensive delete link more

Comments

Okay, I see what you're saying. I have another question though - what do I do about the ROS_PACKAGE_PATH variable? In the tutorial, it says set it like this export ROS_PACKAGE_PATH=~/ros_workspace:/opt/ros/electric/stacks:$ROS_PACKAGE_PATH I looked in my ~/ros/, but I have no directory of stacks. A "find | grep stacks" in ~/ros gives me quite a few files such as ./ros/core/roslib/src/roslib/stacks.py, but no stacks/ directory. I just changed mine to ~/ros_workspace:~/ros/stacks:$ROS_PACKAGE_PATH and did a source setup.sh, and no error messages were outputted. Then I did echo $ROS_PACKAGE_PATH and got an enormous path when it should only be one line. Do you why this may be?

sterlingm gravatar image sterlingm  ( 2012-04-22 11:49:49 -0500 )edit

wait the common stack in the example tutorial is in ~/ros so I just put the $ROS_PACKAGE_PATH to be ROS_PACKAGE_PATH=~/ros_workspace:~/ros/:$ROS_PACKAGE_PATH. Now I can do rospack find bfl with a successful output. I'm guessing most of these directories in ~/ros are stacks then. Can anyone confirm?

sterlingm gravatar image sterlingm  ( 2012-04-22 12:06:52 -0500 )edit

All you should need to do is ROS_PACKAGE_PATH=~/ros_workspace:$ROS_PACKAGE_PATH . The setup.bash file in ~/ros should already have put all the stacks installed with rosinstall on your ROS_PACKAGE_PATH.

Eric Perko gravatar image Eric Perko  ( 2012-04-22 12:24:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-22 11:01:26 -0500

Seen: 940 times

Last updated: Apr 22 '12