Ask Your Question
0

cannot roslaunch moveit_planning_execution.launch

asked 2017-10-17 02:03:58 -0500

tengfei gravatar image

updated 2017-10-17 03:15:21 -0500

Hi all! I'm following the tutorial of industrial Create_a_MoveIt_Pkg_for_an_Industrial_Robot. When I stepped into the 2.Update Configuration Files and completed the moveit_planning_execution.launch, I tried roslaunch it,but it failed. Something was wrong like this:

redefining global property: pi
when processing file: /home/shantengfei/catkin_ws/src/jaka/urdf/jaka.urdf.xacro
while processing /home/shantengfei/catkin_ws/src/jaka_ur_moveit_config/launch/move_group.launch:
while processing /home/shantengfei/catkin_ws/src/jaka_ur_moveit_config/launch/trajectory_execution.launch.xml:
while processing /home/shantengfei/catkin_ws/src/jaka_ur_moveit_config/launch/jakaUr_moveit_controller_manager.launch.xml:
Invalid roslaunch XML syntax: not well-formed (invalid token): line 8, column 0
The traceback for the exception was written to the log file

wrong. I defined the pi in xacro.So is this wrong? In addition, there is a tip "Invalid roslaunch XML syntax: not well-formed (invalid token): line 8, column 0 The traceback for the exception was written to the log file". Here is the launch file: <launch>

  <!-- Non-standard joint names:
       - Create a file jaka_ur_moveit_config/config/joint_names.yaml
       controller_joint_names: [joint_1, joint_2, ... joint_N] 
   - Update with joint names for your robot (in order expected by rbt controller)
   - and uncomment the following line: -->


 <!-- <rosparam command="load" file="$(find jaka_ur_moveit_config)/config/joint_names.yaml"/> -->

  <!-- the "sim" argument controls whether we connect to a Simulated or Real robot -->
  <!--  - if sim=false, a robot_ip argument is required -->
  <arg name="sim" default="true" />
  <arg name="robot_ip" unless="$(arg sim)" />


  <!-- load the robot_description parameter before launching ROS-I nodes -->
  <include file="$(find jaka_ur_moveit_config)/launch/planning_context.launch" >
    <arg name="load_robot_description" value="true" />
  </include>

  <!-- run the robot simulator and action interface nodes -->
  <group if="$(arg sim)">
    <include file="$(find industrial_robot_simulator)/launch/robot_interface_simulator.launch" />
  </group>

  <!-- run the "real robot" interface nodes -->
  <!--   - this typically includes: robot_state, motion_interface, and joint_trajectory_action nodes -->
  <!--   - replace these calls with appropriate robot-specific calls or launch files -->
  <group unless="$(arg sim)">
    <include file="$(find [robot_interface_pkg])/launch/robot_interface.launch" >
      <arg name="robot_ip" value="$(arg robot_ip)"/>
    </include>
  </group>



 <!-- publish the robot state (tf transforms) -->
  <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher" />

  <include file="$(find jaka_ur_moveit_config)/launch/move_group.launch">
    <arg name="publish_monitored_planning_scene" value="true" />
  </include>

  <include file="$(find jaka_ur_moveit_config)/launch/moveit_rviz.launch">
    <arg name="config" value="true"/>
  </include>

  <include file="$(find jaka_ur_moveit_config)/launch/default_warehouse_db.launch" />

</launch>

So could anyone please tell me how to solve this problem?

edit retag flag offensive close merge delete

Comments

The problem is in your jaka_ur_controller_manager.launch.xml, not in moveit_planning_execution.launch according to the error message.

gvdhoorn gravatar imagegvdhoorn ( 2017-10-17 02:59:08 -0500 )edit

And: please do not use images to show us your console. It is all plain text. Just copy-paste the console text into your question, select it and press the Preformatted Text button (the one with 101010 on it).

gvdhoorn gravatar imagegvdhoorn ( 2017-10-17 02:59:56 -0500 )edit

Sorry about the picture.And i found the problem.Thanks for your reply and would you please add an answer then I can make it the rigth method.

tengfei gravatar imagetengfei ( 2017-10-17 05:39:04 -0500 )edit

If you found the problem then it would make sense for you to post an answer and to accept your own answer. That way the question is clearly marked as answered, and with the proper solution.

gvdhoorn gravatar imagegvdhoorn ( 2017-10-17 06:33:32 -0500 )edit

OK,Thank you!

tengfei gravatar imagetengfei ( 2017-10-17 06:37:35 -0500 )edit

I'm sorry I cannot mark my own answer as the corret one because it works until I get 10 points.

tengfei gravatar imagetengfei ( 2017-10-17 06:44:03 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-10-17 06:41:50 -0500

tengfei gravatar image

As gvdhoorn said that I open the jaka_ur_controller_manager.launch.xml and found that there is no "/>"at the end. Although I never edited this file and I didn't know why it lacked them, once i put them up, it worked. Thanks for gvdhoorn's help!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-10-17 02:03:58 -0500

Seen: 523 times

Last updated: Oct 17 '17