Ask Your Question
1

rviz dows not display model (urdf tutorial)

asked 2017-10-10 08:39:59 -0600

Westranger gravatar image

updated 2017-10-10 10:05:14 -0600

I have just installed ROS lunar on Ubuntu 17.04. I wanted to start with the urdf tutorial and tried to display the second model (02-multipleshapes.urdf) but rviz does not display the model. I do see the RobotModel Entry on the left side in the TreeView, the links are also there. But in the 3D view in the center I can only see an 3D axis with not mesh.

image description

edit:

rosparam get /robot_description

outputs

"<?xml version=\"1.0\" ?>\n<!-- ===================================================================================\
  \ -->\n<!-- |    This document was autogenerated by xacro from /home/secret-path-to-my-workspace/urdf/01-myfirst.urdf\
  \ | -->\n<!-- |    EDITING THIS FILE BY HAND IS NOT RECOMMENDED                \
  \                 | -->\n<!-- ===================================================================================\
  \ -->\n<robot name=\"myfirst\">\n  <link name=\"base_link\">\n    <visual>\n   \
  \   <geometry>\n        <cylinder length=\"0.6\" radius=\"0.2\"/>\n      </geometry>\n\
  \    </visual>\n    <collision>\n      <geometry>\n        <cylinder length=\"0.6\"\
  \ radius=\"0.2\"/>\n      </geometry>\n    </collision>\n  </link>\n</robot>\n\n

which is actually the the same urdf file like in the tutorial (except for the collision part)

edit retag flag offensive close merge delete

Comments

Without an image it's probably going to be hard to help you, so please attach one. I've just given you enough karma to do that.

gvdhoorn gravatar imagegvdhoorn ( 2017-10-10 08:52:26 -0600 )edit

@gvdhoorn thank you very much, I just added the image

Westranger gravatar imageWestranger ( 2017-10-10 08:56:52 -0600 )edit

Can you make sure that robot_description contains the urdf that you think it does?

A rosparam get /robot_description should show that.

gvdhoorn gravatar imagegvdhoorn ( 2017-10-10 09:59:01 -0600 )edit

yes it does, I updated by post accordingly. I was switsching between the first and the second model form the turoial, both don't work for me. To me it looks like rviz does start but it cant visualize anything

Westranger gravatar imageWestranger ( 2017-10-10 10:07:05 -0600 )edit
1

This could be caused by locale settings. See ros-visualization/rviz#1151.

gvdhoorn gravatar imagegvdhoorn ( 2017-11-20 09:26:11 -0600 )edit

@gvdhoorn my main system locale is in german and the VM where it worked was in english, I'll have a look into it

Westranger gravatar imageWestranger ( 2017-11-20 09:32:10 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
4

answered 2018-07-09 17:03:14 -0600

dhood gravatar image

updated 2019-11-09 10:30:43 -0600

gvdhoorn gravatar image

Edit (2019-09-09): according to the latest comments on ros/urdfdom_headers#45 (specifically this one), the update to urdfdom_headers with the fix for non-US locales should be released for Ubuntu Bionic.

After installing the latest updates for Bionic overriding LC_NUMERIC should no longer be necessary.


original answer: highlighting @gvdhoorn's previous suggestion (for others that come across this issue) that the issue may be related to locales.

Some rviz users have encountered a similar issue on newer ubuntu/debian versions e.g. ROS Lunar on Ubuntu Artful or ROS Melodic on Ubuntu Bionic (see for example: https://github.com/ros-visualization/...).

If that's the underlying issue, modifying the following environment variable will fix it:

export LC_NUMERIC="en_US.UTF-8".

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-10-10 08:39:59 -0600

Seen: 1,140 times

Last updated: Nov 09