ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

error while using the pocketsphinx package

asked 2017-09-16 18:15:59 -0500

ShehabAldeen gravatar image


I am using ubuntu 16.04 and ROS kinetic and I am trying to run the follwoing command

roslaunch pocketsphinx robocup.launch

and I got that error every time

setting /run_id to e5e01de0-9b34-11e7-8bfa-a4173173d1ff
process[rosout-1]: started with pid [26196]
started core service [/rosout]
process[recognizer-2]: started with pid [26203]
[INFO] [1505603716.914387]: Launch config: gconfaudiosrc
/home/shehabaldeen/catkin_ws/src/pocketsphinx/nodes/ SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'. Please see for more information. = rospy.Publisher('~output', String)
[INFO] [1505603716.924332]: Starting recognizer... 
Traceback (most recent call last):
  File "/home/shehabaldeen/catkin_ws/src/pocketsphinx/nodes/", line 177, in <module>
    start = recognizer()
  File "/home/shehabaldeen/catkin_ws/src/pocketsphinx/nodes/", line 73, in __init__
  File "/home/shehabaldeen/catkin_ws/src/pocketsphinx/nodes/", line 80, in start_recognizer
    self.pipeline = gst.parse_launch(self.launch_config)
glib.GError: no element "vader"
Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/rospy/", line 467, in signal_shutdown
  File "/home/shehabaldeen/catkin_ws/src/pocketsphinx/nodes/", line 131, in shutdown
RuntimeError: called outside of a mainloop
[recognizer-2] process has died [pid 26203, exit code 1, cmd /home/shehabaldeen/catkin_ws/src/pocketsphinx/nodes/ __name:=recognizer __log:=/home/shehabaldeen/.ros/log/e5e01de0-9b34-11e7-8bfa-a4173173d1ff/recognizer-2.log].
log file: /home/shehabaldeen/.ros/log/e5e01de0-9b34-11e7-8bfa-a4173173d1ff/recognizer-2*.log

I have the pocketshpinx installed and the sphinxbase as well the error is same as here and here and I saw the answers says to run this command which I have done

sudo apt-get install gstreamer0.10-gconf

I tried also to run

 sudo apt-get install gstreamer0.10-pocketsphinx

but it gives me the following error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package gstreamer0.10-pocketsphinx
E: Couldn't find any package by glob 'gstreamer0.10-pocketsphinx'
E: Couldn't find any package by regex 'gstreamer0.10-pocketsphinx'

and still having the same error if any one have suggestions or any one can help please

thank you

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-09-16 19:03:52 -0500

AndyZe gravatar image
edit flag offensive delete link more

Question Tools



Asked: 2017-09-16 18:15:59 -0500

Seen: 980 times

Last updated: Sep 16 '17