Ask Your Question
0

Error:cannot launch node [octomap_server/octomap_server_node]

asked 2017-09-04 17:14:52 -0600

Eyshika gravatar image

updated 2017-09-07 11:29:15 -0600

Hello I am trying to convert my point cloud data into map using octomap. I am newbie in this, so i would like to know what I am doing wrong. To create map these are steps I followed:

  1. rosbag info<mypoint_cloudbagfile> : OUTPUT: gives all the required information appropriately
  2. rosbag play <mypoint_cloudbagfile> Output
  3. Created my own Package
  4. Inside launch folder added this data: https://github.com/OctoMap/octomap_ma...
  5. Updated Package.xml with required dependencies Package.xml
  6. Updated CmakeLists.txt like this:

    cmake_minimum_required(VERSION 2.8.3)
    project(octomap_server)
    
    
    
    set(PACKAGE_DEPENDENCIES
      roscpp
      rospy
      std_msgs
      pcl_ros
      pcl_conversions
      visualization_msgs
      nav_msgs
      octomap_ros
      octomap_msgs
      #dynamic_reconfigure
      nodelet
      sensor_msgs
    )
    
    
    find_package(catkin REQUIRED COMPONENTS ${PACKAGE_DEPENDENCIES})
    
    find_package(PCL REQUIRED QUIET COMPONENTS common sample_consensus io segmentation filters)
    
    find_package(octomap REQUIRED)
    
    include_directories(
     include
     $(catkin_INCLUDE_DIRS)
     $(PCL_INCLUDE_DIRS)
     $(OCTOMAP_INCLUDE_DIRS)
    )
    catkin_package(
      INCLUDE_DIRS include
      LIBRARIES ${PROJECT_NAME}
      CATKIN_DEPENDS ${PACKAGE_DEPENDENCIES}
      DEPENDS octomap PCL
    )
    
    set(LINK_LIBS
        ${OCTOMAP_LIBRARIES}
        ${catkin_LIBRARIES}
        ${PCL_LIBRARIES}
    )
    
  7. ran launch file :

    roslaunch octomap_server octomap_mapping.launch
    

It runs but gives this error:

OUTPUT: ERROR: cannot launch node of type [octomap_server/octomap_server_node]: can't locate node [octomap_server_node] in package [octomap_server]

P.S.: I have already installed octomap_mapping using

sudo apt-get install ros-kinetic-octomap_mapping

Please tell me why this error occurs and how can I repair it to proceed in creating a map.

There are some solutions I tried: 1. run rosrun octomap_server octomap_server_node to check node

I got this output:

Couldn't find executable named octomap_server_node below /home/ubuntu/catkin/src/octomap_server

2. Source the bash file using:

source ~/catkin_ws/devel/setup.bash

Thank You!

edit retag flag offensive close merge delete

Comments

Welcome. I edited your question to make it more readable. In the future, please format any terminal output/source code/etc. using the 101010 button to make it more readable.

jayess gravatar imagejayess ( 2017-09-04 19:24:29 -0600 )edit

Thanx a lot.

Eyshika gravatar imageEyshika ( 2017-09-05 10:19:05 -0600 )edit

Are modifying the package.xml and CMakeLists.txt of the package that you downloaded? If so, why? Also, did you run catkin_make from the root for your workspace? I don't see that step listed.

jayess gravatar imagejayess ( 2017-09-08 10:34:05 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-09-04 19:27:08 -0600

jayess gravatar image

updated 2017-09-05 09:48:41 -0600

This question pops up quite regularly and the solution is usually the same, source the setup.bash file:

source ~/catkin_ws/devel/setup.bash

Where catkin_ws is your catkin workspace. You can always Google the error to find a solution before posting a question:

https://www.google.com/search?q=OUTPU...

edit flag offensive delete link more

Comments

Using Google to search ROS Answers is a good suggestion.

My suggestion: add site:answers.ros.org to the query. That will limit results to just this site.

gvdhoorn gravatar imagegvdhoorn ( 2017-09-05 03:08:55 -0600 )edit

Good call. I updated the query to limit results to this site.

jayess gravatar imagejayess ( 2017-09-05 09:49:14 -0600 )edit

@jayess : I have already done that. My workspace bash file is already sourced. I googled the answer for this error and couldn't get the correct solution. that's why i thought of posting new question since it might be issue in Octomap_maping.

Eyshika gravatar imageEyshika ( 2017-09-05 10:18:01 -0600 )edit

@Eyshika: Without that information people are going to give to you the most common solution to that problem. Please update your question with what you have tried and what the results were.

jayess gravatar imagejayess ( 2017-09-05 10:40:22 -0600 )edit

@jayess: I have updated my query. please check .

Eyshika gravatar imageEyshika ( 2017-09-07 11:29:41 -0600 )edit
1

answered 2019-04-10 12:52:38 -0600

meadows gravatar image

I got the exact problem and here is what I did to resolve it on ros kinetic:

  1. Run (to install ros octomap packages): sudo apt-get install ros-kinetic-octomap ros-kinetic-octomap-mapping ros-kinetic-octomap-msgs ros-kinetic-octomap-ros ros-kinetic-octomap-rviz-plugins ros-kinetic-octomap-server

  2. Rebuild your workspace (i.e catkin_make)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-04 17:10:07 -0600

Seen: 1,385 times

Last updated: Sep 07 '17