Moveit stuck interactive marker

asked 2017-07-31 08:00:13 -0600

Shine gravatar image

updated 2017-08-01 04:07:08 -0600

I tried generating ikfast plugin for my custom robot.Except ikfast all other kinematic plugins are working.If i set ikfast as the kinematic solver,i am not able to move the interactive marker in rviz.I tried almost all permutations and combinations for fixing it.But not able to solve it.I am attaching the robot package in the google drive.I will be happy if someone can help me.

The robot name is innova.Here is the google link for the same : https://drive.google.com/file/d/0B0BF...

edit retag flag offensive close merge delete

Comments

Make sure your robot is not in a singularity. Planning to pose goals can work, but dragging the marker won't in that case.

If you're sure that is not the case: have you run the IK tests that OpenRAVE supports? They should tell you whether your plugin is actually working.

gvdhoorn gravatar image gvdhoorn  ( 2017-07-31 08:08:39 -0600 )edit

hey, i'm having the same problem for an 7 dof robot. did you find a way to fix it?

lbalog gravatar image lbalog  ( 2017-08-14 14:54:22 -0600 )edit