Ask Your Question
0

Problem installing turtlebot

asked 2017-07-17 19:54:51 -0500

Nexo gravatar image

Hello everyone, I'm new here and I'm trying to install turtlebot on a Raspberry Pi 2's Ubuntu OS. I've already installed ROS without errors and now I'm trying to install the Turtlebot following these instructions: http://wiki.ros.org/turtlebot/Tutoria... I went directly to 1.2.2 Ubuntu Package Install and ran that code but I get the following error every single time:

Unable to locate package ros-indigo-turtlebot-simulator.

Searching on Google I found the next question: http://answers.ros.org/question/21348... Then the op says he/she found a workaround doing the following:

sudo apt-get install libsdformat1

Then:

sudo apt-get install ros-indigo-turtlebot ros-indigo-turtlebot-apps ros-indigo-turtlebot-interactions ros-indigo-turtlebot-simulator ros-indigo-kobuki-ftdi ros-indigo-rocon-remocon ros-indigo-rocon-qt-library ros-indigo-ar-track-alvar-msgs

Although it worked for him/her, it didn't work for me so I kept searching and found the next question:

http://answers.ros.org/question/22429...

The answer chosen as the correct one gives some directions even after following them I'm still unable to correct the error I showed you. One of the comments on that questions says:

Have you modified your /etc/apt/sources.list or any of the files in /etc/apt/sources.list.d/ since you installed ROS?

And I did modify because I had some problems when I was installing ROS and now that file looks like this:

deb http://ports.ubuntu.com/ubuntu-ports/ trusty main universe multiverse restr$
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty main universe multiverse r$
deb http://ports.ubuntu.com/ubuntu-ports/ trusty-updates main universe multiver$
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty-updates main universe mult$
deb http://ports.ubuntu.com/ubuntu-ports/ trusty-security main universe multive$
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty-security main universe mul$

Maybe this is the problem, does anybody know how to correct this? I really want to start working with the turtlebot.

Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-07-17 23:23:46 -0500

ahendrix gravatar image

The turtlebot simulator depends on gazebo, and gazebo isn't available for Ubuntu running on the Raspberry Pi 2.

Assuming that you're followed the installation instructions on http://wiki.ros.org/indigo/Installati... , if you follow the link to the package status page and search for turtlebot_simulator ( http://repositories.ros.org/status_pa... ), you can see that the Thf column for turtlebot_simulator is red, indicating that the binary package isn't available for Trusty.

This usually happens because there are missing dependencies or compilation errors when trying to build packages on ARM, and they don't usually get fixed because there is low demand for these packages, and many of the complex simulation packages like Gazebo run too slowly on ARM to be useful anyway.

I suggest that you install the turtlebot_simulator package on an x86 desktop, laptop, or virtual machine instead.

edit flag offensive delete link more

Comments

Thank you very much for your answer! I would really like to install it on a desktop computer or a laptop but we need to install it in the RPi2 because we are making a small car-robot base on this embedded system. Is there a workaround? Maybe to install it on a RPi3 using Ubuntu?

Nexo gravatar image Nexo  ( 2017-07-17 23:33:56 -0500 )edit

We tried installing ROS using Raspbian but we got too many errors and it was impossible to find a workaround. Any suggestion will be really appreciated.

Nexo gravatar image Nexo  ( 2017-07-17 23:35:24 -0500 )edit

To be able to run the base turtlebot packages you don't need to install the simulator on your RPi. In fact, I would rather not do that, as the Pi is really not powerful enough to comfortably run something like Gazebo.

gvdhoorn gravatar image gvdhoorn  ( 2017-07-18 01:56:23 -0500 )edit

Thank you very much, I've installed Ubuntu on my laptop which will dual-boot along with my Windows OS and then installed ROS without problems. Thanks you for your help and I apologize for taking too long to answer back.

Nexo gravatar image Nexo  ( 2017-07-26 13:55:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-17 19:52:32 -0500

Seen: 632 times

Last updated: Jul 17 '17