Ask Your Question
0

Use STOMP as planner in moveit

asked 2017-07-03 23:59:37 -0500

fittaoee gravatar image

updated 2017-07-04 19:57:30 -0500

I'm trying to use STOMP in moveit as the path-planner, instead of using the default planner. I've followed all the steps here: https://github.com/ros-industrial/ind... . First I created a “stomp_planning_pipeline.launch.xml” file, then the "stomp_planning.yaml" configuration file, and modified the "parameter" value in ”move_group.launch“. I've made sure the file paths are correct. I also had the following lines of code in my cpp file to set the planner to STOMP:

moveit::planning_interface::MoveGroup group("arm");
group.setPlannerId("STOMP");

Since I wasn't sure how to install the STOMP plugin, I just ran the command "sudo apt-get install ros-indigo-stomp-moveit", which, along with the stomp-moveit plugin, also installed the stomp-core plugin. I also installed the industrial_moveit plugin. However, when I ran the launch file, I'm getting the following error:

[ERROR] [1499143566.205198927]: The 'stomp' configuration parameter was not found terminate called after throwing an instance of 'std::runtime_error'
what(): Unable to initialize planning plugin

I'm using Indigo. My stomp_planning.yaml file is almost ideal to this one except the group name: https://github.com/ekuri/baxter_movei...

Any help is appreciated. Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
2

answered 2017-07-05 07:34:38 -0500

Levi-Armstrong gravatar image

Hello,

I reviewed your moveit config and it looks like your config file is not setup correctly. Please take a look at the one below. All parameters for a group should be name spaced "stomp/group_name:" so in your case it should "stomp/arm:", followed by the parameter "group_name: arm". Also could you provide a link to the config file you used to create yours from? It contains additional parameters that I cannot find being used in the source code.

STOMP Config

edit flag offensive delete link more

Comments

Thank you! I copied the config file you provided and changed the group_name, and that error was gone. However, now I see another error, which says: [ERROR] [1499307738.017898024]: STOMP: Can only handle joint space goals. What might be the cause of this? Thanks again.

fittaoee gravatar image fittaoee  ( 2017-07-05 21:29:02 -0500 )edit

I saw your answer in a google group that one should "use the RobotState::setFromIK to get a set of joints for the given pose and pass that to STOMP to solve the issue". But I wonder how exactly should I pass something of type "robot_state::RobotState" to STOMP? Any example code that I follow? Thanks

fittaoee gravatar image fittaoee  ( 2017-07-05 21:46:06 -0500 )edit

Take a look here. You want to set a joint goal.

Levi-Armstrong gravatar image Levi-Armstrong  ( 2017-07-06 08:42:30 -0500 )edit
1

answered 2017-07-05 09:43:19 -0500

Hello The configuration file you pointed to corresponds to an old version of stomp. The link provided in the first answer points to the new configuration file format. For more details on the configuration file go to the link below.

stomp_moveit

edit flag offensive delete link more

Comments

Thank you.

fittaoee gravatar image fittaoee  ( 2017-07-05 21:29:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-07-03 23:59:37 -0500

Seen: 797 times

Last updated: Jul 05 '17