ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Initialize Failed with SICK LMS 5xx

asked 2017-06-05 21:17:19 -0500

sai gravatar image

Hi all,

I m using the ROS driver for SICK LMS511-10100 from here:

This returns me an error saying:

*** iirav@iirav:~$ rosrun laser_node laser_node       

Attempting to connect to Sick LMS 5xx @                                               A Timeout Occurred - SickLMS5xx::_setupConnection: select() timeout!                             A Timeout Occurred - SickLMS5xx::_setupConnection: select() timeout!                               [ERROR] [1496664746.220065882]: Initialize failed!

I also tried, setting one of the ethernet port to, but still ending up with the same error.

Can anyone help in getting this to work ?

edit retag flag offensive close merge delete


@sai I'm not familiar with this method of rangefinder. As stated below, I'd suggest you try pinging it to see if you can see it, otherwise check that that port in particular can be reached.

allenh1 gravatar image allenh1  ( 2017-06-06 13:27:03 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-06-06 05:43:06 -0500

vik748 gravatar image

Make sure you are able to ping the Lidar first before trying to use the driver. If you are unable to ping try changing network settings. If that doesn't help try using the SICK software on a windows computer to communicate with the LMS.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-06-05 21:17:19 -0500

Seen: 597 times

Last updated: Jun 06 '17