Ask Your Question
0

Using a map on RVIZ

asked 2017-05-13 03:36:57 -0500

little_bob gravatar image

updated 2017-05-14 22:54:28 -0500

AlexR gravatar image

Hi,I follow the book Ros By Example.I use the method mentioned in this book to generating a map with the XV_11 laser scanner.And it seems that the my_map.pgm is 4.1MByte, and when I load this map,RVIZ becomes lagging.And warnnings show upon the terminal:

1、Control loop missed its desired rate:3.0 HZ,it actually takkes 1.3193s

2、Map update missed its desired rate:3.0 HZ,it actually takes 25.098s

Why? I just changed the test_map.pgm with my_map.pgm.Using test_map.pgm is OK and works really well.Maybe it is because my_map.pgm is too big?(test_map.pgm is only 300KB) So are there any ways to cut the .pgm file to a small size or just filter the white areas?(the scanned mapmy_map.pgmis 2048x2048,I think it is too large)

PS:I tried set the update_frequency in local_costmap_params.yaml to 1HZ,reduce theheight width to 3.0*3.0,reduce the controller_frequency in base_local_planner_params.yaml to 1HZ,but these didn't work. paste my distro:I run ros Hydro on a Vmware machine(Mem:3G,Cpucores:2),the host is I5-3230M RAM:8G 64bits Lenovo Y400

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2017-05-14 09:52:19 -0500

little_bob gravatar image

updated 2017-05-14 09:52:45 -0500

OK,guys.I actually solved this problem by this way: I open this my_map.pgm with PhotoShop.Then I aborted the none-blank areas,reduce it to 574x544pixels(300kb).And then,everything works fine after this.So,the reason is the map is too large for the Vmware machine to afford it.Should I close this question to show it solved?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-13 03:36:57 -0500

Seen: 526 times

Last updated: May 14 '17