Ask Your Question
0

rtabmap_ros doesnt display any output

asked 2017-05-08 09:19:36 -0500

shashankbhat gravatar image

Hi,

I am new to rtabmap_ros. I have installed rtabmap_ros for indigo & was following steps mentioned in

to run the demo_mapping.bag file. The problem is rtabmap_ros will open but nothing is getting displayed.

Can anyone help me out to solve this.

edit retag flag offensive close merge delete

Comments

What exact commands did you use?

matlabbe gravatar image matlabbe  ( 2017-05-08 09:27:31 -0500 )edit

roslaunch rtabmap_ros demo_robot_mapping.launch rosbag play --clock demo_mapping.bag

shashankbhat gravatar image shashankbhat  ( 2017-05-08 23:41:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-05-09 09:29:24 -0500

matlabbe gravatar image

Cannot reproduce the problem (Indigo binaries, version 0.11.8):

$ roslaunch rtabmap_ros demo_robot_mapping.launch
$ rosbag play --clock demo_mapping.bag

image description

If you launch with RVIZ, do you see something?

$ roslaunch rtabmap_ros demo_robot_mapping.launch rviz:=true rtabmapviz:=false
edit flag offensive delete link more

Comments

Even when I run roslaunch rtabmap_ros demo_robot_mapping.launch rviz:=true rtabmapviz:=false, I wont get any display

shashankbhat gravatar image shashankbhat  ( 2017-05-09 23:00:17 -0500 )edit

Can you copy/paste the terminal output in your question?

matlabbe gravatar image matlabbe  ( 2017-05-11 16:54:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-08 09:19:36 -0500

Seen: 130 times

Last updated: May 09 '17