ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
1

Help migrating from robot_pose_ekf to robot_localization [closed]

asked 2017-04-29 09:37:10 -0600

blasalat gravatar image

Hi, I am currently trying to migrate to robot_localization. I am using IMU and odometry data for the ekf_localization_node. When running ekf_localization_node I get a tf error:

Error:   TF_NAN_INPUT: Ignoring transform for child_frame_id "base_footprint" from authority "unknown_publisher" because of a nan value in the transform (-nan -nan -nan) (-nan -nan -nan -nan)
         at line 240 in /tmp/binarydeb/ros-kinetic-tf2-0.5.15/src/buffer_core.cpp
Error:   TF_DENORMALIZED_QUATERNION: Ignoring transform for child_frame_id "base_footprint" from authority "unknown_publisher" because of an invalid quaternion in the transform (-nan -nan -nan -nan)
         at line 253 in /tmp/binarydeb/ros-kinetic-tf2-0.5.15/src/buffer_core.cpp

Here is a Bagfile I made containing IMU and Odometry data. My cofing:

frequency: 30
sensor_timeout: 0.1
two_d_mode: false
transform_time_offset: 0.0
transform_timeout: 0.0
print_diagnostics: true
debug: false
publish_tf: true
publish_acceleration: false
odom_frame: odom_combined            # Defaults to "odom" if unspecified
base_link_frame: base_footprint  # Defaults to "base_link" if unspecified
world_frame: odom_combined           # Defaults to the value of odom_frame if unspecified

odom0: odom
odom0_config: [true,  true,  false,
               false, false, true,
               true,  false, false,
               false, false, true,
               false, false, false]
odom0_queue_size: 2
odom0_nodelay: false
odom0_differential: true
odom0_relative: false
odom0_pose_rejection_threshold: 5
odom0_twist_rejection_threshold: 1

imu0: imu/data
imu0_config: [false, false, false,
              true,  true,  true,
              false, false, false,
              true,  true,  true,
              true,  true,  true]
imu0_nodelay: false
imu0_differential: true
imu0_relative: true
imu0_queue_size: 5
imu0_pose_rejection_threshold: 0.8                 # Note the difference in parameter names
imu0_twist_rejection_threshold: 0.8                #
imu0_linear_acceleration_rejection_threshold: 0.8  #
imu0_remove_gravitational_acceleration: true

Any chance someone can help me figure this out.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by blasalat
close date 2017-08-23 09:29:09.049875

Comments

Please post sample messages for each EKF input. Also, post any static transforms you are publishing.

Tom Moore gravatar image Tom Moore  ( 2017-05-04 04:30:13 -0600 )edit

It seems like you haven't specified a map_frame parameter.

ufr3c_tjc gravatar image ufr3c_tjc  ( 2017-05-15 01:56:36 -0600 )edit

It defaults to map. Did you ever solve this? If so, can we close the question?

Tom Moore gravatar image Tom Moore  ( 2017-07-25 09:29:44 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-08-23 09:28:18 -0600

blasalat gravatar image

Hi, sorry for responding so late. The error occurred due to nan values in my odom messages.

edit flag offensive delete link more

Comments

the same problem for me

please help me

thank you in advance

Redhwan gravatar image Redhwan  ( 2019-05-15 23:36:31 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-04-29 09:37:10 -0600

Seen: 941 times

Last updated: Apr 29 '17