hello everyone, I want to do skeleton tracking with my kinect 1414 on my raspberry pi 3 running ubuntu mate 16.04

asked 2017-04-18 14:39:03 -0500

hamza_ENPO gravatar image

I followed this tutorial to install OpenNI and SensorKinect, than I installed NITE v1.5.2.23 (x86) on exagear desktop session, because I didn't find NITE compiled for Arm, than out of the x86 session I installed openni_launch than I added openni_tracker to my work space than I used catkin_make. roslaunch openni_launch openni.launch runs normally, but when I run rosrun openni_tracker openni_tracker I get the error "InitFromXml failed: Failed to set USB interface!" , notice that NITE is working because when I run /OpenNI-unstable/Platform/Linux/Bin/x86-Release$ sudo ./Sample-NiSimpleSkeleton it run properly but without running openni_launch, and one I run openni_launch and then run sudo ./Sample-NiSimpleSkeleton it give me the same problem "Open failed: Failed to set USB interface!" thank you.

edit retag flag offensive close merge delete