Ask Your Question
0

Pixhawk not publishing the local position of my Quadrotor

asked 2017-04-01 01:28:14 -0600

Karthikeya Parunandi gravatar image

I am on Ubuntu 14.04 (ROS Indigo). I run "roslaunch mavros px4.launch" and am able to successfully connect to my quadrotor. I have a working GPS signal and also could see the data being published on "/mavros/global_position/local". However, no data is being published on "/mavros/local_position/pose". When I run the gazebo simulation, data is being published on "/mavros/local_position/pose". What could be the possible solution to this?

Thanks in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-08-01 08:27:30 -0600

hi! In order to start the internal ekf2 estimator to see any activity on mavros/local_position/pose, you need to thick the box on the EKF2_AID_MASK (use vision / use yaw fusion)! hope it can help

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-04-01 01:28:14 -0600

Seen: 262 times

Last updated: Aug 01 '18