Ask Your Question
0

Ethernet Problem with URG-04LX [closed]

asked 2017-03-29 05:21:11 -0500

JustaLinuxLover gravatar image

updated 2017-03-29 06:16:37 -0500

Hey everyone, I ran to this issue yesterday and been trying to fix it ever since with no luck. My URG-04LX works fine with usb but since I want to use it over the wi-fi (right now, I'm testing it with a LAN cable), I've connected it to my laptop, with a RS232-to-Ethernet converter. On windows, I can send and receive it's data with COM, on my 14.04 LTS ubuntu however I get this message when I use urg_node:
--------------------------------------------------------------------------------------------------------
(some directory)@user:~$ rosrun urg_node urg_node _ip_address:="192.168.1.7"
Error connecting to Hokuyo: Could not open network Hokuyo: 192.168.1.7:10940 could not open ethernet port.
--------------------------------------------------------------------------------------------------------

I've already set my Laptop's Ethernet IP address to the RS232-to-Ethernet converter's destination IP and I'm communicating the urg_node with the 115200 baud-rate (which URG-04LX seems to work on it by default) through the 10940 port (again, it's default port). I've tried various solutions provided by other people on the Internet with no luck.
I sincerely appreciate any and every help.
Note: I found a forum that suggested to use a embedded system like raspberry pie or ODROID in order to read data and use a bridge connection to run the urg_node remotely from my laptop but using this way is not applicable in my case.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by JustaLinuxLover
close date 2017-06-30 16:24:33.017528

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-30 16:23:53 -0500

JustaLinuxLover gravatar image

Hey again,
decided to solve the problem by using an embedded system along the way and a mini-usb cable to receive the data from my hokuyo since it looks like it's difficult for urg_node to communicate with my laser through a ethernet-to-usb converter. (Reads the data through /dev/ttyUSB0 but it has some weird troubles like not being able to shut the node down :? )
so just decided to give an update on this post and close it, feel free to ask any other related questions about urg_node and hokuyo connection from me :)

Best of luck to you all

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-03-29 05:11:58 -0500

Seen: 424 times

Last updated: Jun 30 '17