Ask Your Question
0

Not able to find ros-kinetic-desktop-full

asked 2017-03-15 13:24:03 -0600

Padam Sethia gravatar image

I've followed all the steps given , but cannot find the above package. Also checked all the packages but cannot find ros-kinetic. I'm running Ubuntu 16.10

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-03-15 13:32:07 -0600

ahendrix gravatar image

updated 2017-03-15 13:32:19 -0600

The ROS install instructions specifically state that only Ubuntu 15.10 and 16.04 are supported; you cannot install ROS through apt on 16.10.

I recommend that you switch to Ubuntu 16.04 (it's their long-term stable release anyway) or install from source.

edit flag offensive delete link more

Comments

Indeed:

ROS Kinetic ONLY supports [..] Xenial (Ubuntu 16.04) [..] with debian packages

gvdhoorn gravatar imagegvdhoorn ( 2017-03-15 13:42:30 -0600 )edit

I tried installing from source , but its showing error .

ERROR: the following packages/stacks could not have their rosdep keys resolved

to system dependencies: rosconsole: No definition of [rosunit] for OS version [yakkety]

?

Padam Sethia gravatar imagePadam Sethia ( 2017-03-15 14:04:05 -0600 )edit

If you have no real need to run 16.10, I strongly advise you install 16.04 and use the provided binaries. It will save you a lot of effort and (potential) frustration.

If you must build from source, you'll have to override the OS detection. See http://wiki.ros.org/ROS/EnvironmentVa... .

gvdhoorn gravatar imagegvdhoorn ( 2017-03-15 14:09:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-03-15 13:24:03 -0600

Seen: 443 times

Last updated: Mar 15 '17