Ask Your Question
0

Failed to validate trajectory after updating moveit (Feb 2017)

asked 2017-02-17 05:37:08 -0500

Wen Xin gravatar image

updated 2017-02-17 20:41:25 -0500

Hello! I am very new to ROS and i'm currently working on gazebo and moveit on ros indigo. I am currently using the "Autonomous-Flight-ROS" code written by AlessioTonioni. Before updating moveit, everything works well. After updating, I have no problem planning a motion but the problem happens when i execute my planning from moveit to gazebo, it gives the error: "Failed to validate trajectory: couldn't receive full current joint state within 1s".

I'm currently using ros indigo, gazebo 2.2.6, moveit last update (Feb 2017), ubuntu 14.04 trusty.

In the terminal, when i try to plan and execute a valid state, it shows

[ INFO] [1487385467.586393924, 55.384000000]: Planning request received for MoveGroup action. Forwarding to planning pipeline.
[ INFO] [1487385467.632584405, 55.416000000]: No optimization objective specified, defaulting to PathLengthOptimizationObjective
[ INFO] [1487385467.633476818, 55.417000000]: Planner configuration 'Quadrotore[PRMstarkConfigDefault]' will use planner 'geometric::PRMstar'. Additional configuration parameters will be set when the planner is constructed.
[ INFO] [1487385467.648647637, 55.427000000]: Quadrotore[PRMstarkConfigDefault]: problem definition is not set, deferring setup completion...
[ INFO] [1487385467.648978360, 55.427000000]: Quadrotore[PRMstarkConfigDefault]: problem definition is not set, deferring setup completion...
[ INFO] [1487385467.649068794, 55.427000000]: Quadrotore[PRMstarkConfigDefault]: problem definition is not set, deferring setup completion...
[ INFO] [1487385467.649106579, 55.427000000]: Quadrotore[PRMstarkConfigDefault]: problem definition is not set, deferring setup completion...
[ INFO] [1487385467.649145390, 55.427000000]: Quadrotore[PRMstarkConfigDefault]: problem definition is not set, deferring setup completion...
[ INFO] [1487385467.651254216, 55.428000000]: Quadrotore[PRMstarkConfigDefault]: Starting planning with 2 states already in datastructure
[ INFO] [1487385467.652344408, 55.428000000]: Quadrotore[PRMstarkConfigDefault]: Starting planning with 2 states already in datastructure
[ INFO] [1487385467.653093549, 55.429000000]: Quadrotore[PRMstarkConfigDefault]: Starting planning with 2 states already in datastructure
[ INFO] [1487385467.659354421, 55.432000000]: Quadrotore[PRMstarkConfigDefault]: Starting planning with 2 states already in datastructure
[ INFO] [1487385472.650616281, 58.683000000]: Quadrotore[PRMstarkConfigDefault]: Created 1391 states
[ INFO] [1487385472.650772184, 58.684000000]: Quadrotore[PRMstarkConfigDefault]: Created 1274 states
[ INFO] [1487385472.650862388, 58.684000000]: Quadrotore[PRMstarkConfigDefault]: Created 1524 states
[ INFO] [1487385472.651784028, 58.685000000]: Quadrotore[PRMstarkConfigDefault]: Created 1402 states
[ INFO] [1487385472.652006827, 58.685000000]: ProblemDefinition: Adding approximate solution from planner PathHybridization
[ INFO] [1487385472.652064502, 58.685000000]: ParallelPlan::solve(): Solution found by one or more threads in 5.002876 seconds
[ INFO] [1487385475.181260991, 60.603000000]: Received new trajectory execution service request...
[ WARN] [1487385476.487933898, 61.609000000]: Failed to validate trajectory: couldn't receive full current joint state within 1s
[ INFO] [1487385476.488162318, 61.609000000]: Execution completed: ABORTED

The rqt_graph is attached below rosgraph.png

I will be grateful if someone could help me on this problem. Thanks..

edit retag flag offensive close merge delete

Comments

1

Please don't use screenshots for text. If you ever remove the screenshot from your google drive, this question becomes worthless. You could easily copy-paste the console text into your question, and use the Preformatted Text button to format it properly.

Thanks.

gvdhoorn gravatar image gvdhoorn  ( 2017-02-17 11:15:54 -0500 )edit

I've also given you enough karma to attach the rqt_graph sshot to this image.

Note btw that as you have it now it's way too small. You might want to change that.

gvdhoorn gravatar image gvdhoorn  ( 2017-02-17 11:17:25 -0500 )edit

Thank you so much! I had edited my question accordingly. Thanks !!

Wen Xin gravatar image Wen Xin  ( 2017-02-17 20:46:57 -0500 )edit

你好,我和你遇到了一样的问题,请问你的问题解决了么?

pyni_sjtu gravatar image pyni_sjtu  ( 2017-04-20 10:30:29 -0500 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2017-02-22 03:53:55 -0500

v4hn gravatar image

updated 2017-02-22 03:56:58 -0500

Your Gazebo setup seems to be incomplete. Nobody publishes to the /joint_states topic and most likely a gazebo plugin should do that.

Addition: Be aware that if trajectory start-state validation does not make sense for your use-case, you can also just disable it by putting this into your moveit_config's launch/trajectory_execution.launch.xml:

<param name="trajectory_execution/allowed_start_tolerance" value="0.0"/>

edit flag offensive delete link more

Comments

Thanks for the help! I installed the plugin by running sudo apt-get install ros-indigo-pr2-gazebo-plugins . Now the gazebo published to /joint_states and /joint_states publishes to /move_group But after installing the plugin, Rviz crashes when executing the planned path.

Wen Xin gravatar image Wen Xin  ( 2017-02-24 02:20:10 -0500 )edit
[move_group-1] process has died [pid 3299, exit code -11,
Wen Xin gravatar image Wen Xin  ( 2017-02-24 02:22:29 -0500 )edit
0

answered 2017-12-11 09:23:54 -0500

rhaschke gravatar image

updated 2017-12-11 09:24:52 -0500

There are several possible reasons for this issue:

  1. As v4hn pointed out, there might be no publisher populating the /joint_states topic.
  2. As reported here, MoveIt might be too busy (e.g. processing perception data) to actually process the joint_states topic.
  3. You are using MoveIt < Kinetic and some joints of your robot are never published on joint_states. MoveIt maintainers are preparing a fix for this.
edit flag offensive delete link more
0

answered 2017-02-17 08:29:08 -0500

FábioBarbosa gravatar image

updated 2017-02-22 07:42:37 -0500

Hi! i had the same problem and posted the same question. Go see this link: http://answers.ros.org/question/25211...

Hope i had helped ;-)

EDIT:

What it is say on the link is to go to the launch file where you call the "move_group.launch" and "moveit_rviz.launch" and paste this lines before the calls of move_group and moveit_rviz launch files:

  <!-- We do not have a robot connected, so publish fake joint states -->
  <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
    <param name="/use_gui" value="false"/>
    <rosparam param="/source_list">[/move_group/fake_controller_joint_states]</rosparam>
  </node>

and it should do the trick for the project to work.

edit flag offensive delete link more

Comments

Hi, thanks for the answer. I'm very new to ROS and MoveIt!. I am kinda confused and I can't really relate the answers from the link you provided with my case. From my rqt graph, move group does subscribed to /joint_states topic. Any help would be greatly appreciated.

Wen Xin gravatar image Wen Xin  ( 2017-02-22 01:39:36 -0500 )edit

The "fix" of FábioBarbosa is not really useful. The fake_controller_joint_states is only used in demo mode of MoveIt and the joint_states topic should be usually populated by your robot driver, but not manually running a joint_state_publisher.

rhaschke gravatar image rhaschke  ( 2017-12-11 09:19:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-02-17 05:37:08 -0500

Seen: 1,495 times

Last updated: Dec 11 '17