Ask Your Question
0

meet error when implementing "velodyne_driver" command for vlp-16

asked 2017-01-30 17:14:05 -0500

Bill5785 gravatar image

updated 2017-02-02 02:05:15 -0500

gvdhoorn gravatar image

I tried to do as the answer to #q213080 says, but when I try the second command

rosrun velodyne_driver velodyne_node _model:=VLP16 _pcap:=/your/pcap/path/data.pcap _read_once:=true

It says

[ERROR] [1485795341.945746381]: unknown Velodyne LIDAR model: VLP16

Does anybody have idea?

[PS] I have git cloned the package from https://github.com/ros-drivers/velody... and https://github.com/ros-drivers/velody... and built the workspace as some other guidance says.


Edit: @gvdhoorn I think you are right. My initial ouput of it is not this. after I sourced the devel/setup.bash, the first question is solved. Now the response is

[FATAL] [1486012428.835246258]: Error opening Velodyne socket dump file.
Segmentation fault (core dumped)
edit retag flag offensive close merge delete

Comments

2

Can you tell us the output of rospack find velodyne_driver?

gvdhoorn gravatar imagegvdhoorn ( 2017-01-31 02:26:03 -0500 )edit

It returns like

/home/wbw/catkin_ws/src/velodyne/velodyne_driver
Bill5785 gravatar imageBill5785 ( 2017-02-01 18:47:10 -0500 )edit

Just making sure: you did replace /your/pcap/path/data.pcap with the actual path to a pcap file, right? Do you actually want to use a 'live' lidar, or do you want to open a capture file that you made earlier? If the former, don't use the _pcap parameter.

gvdhoorn gravatar imagegvdhoorn ( 2017-02-02 02:06:40 -0500 )edit

@gvdhoorn I replaced with the actual path to a pcap file like

/home/wbw/Downloads/2015-05-29-22-49-14_Velodyne-VLP-16-Data.pcap.

This is a capture file and I didn't mean to use live lidar data. Am I doing right?

Bill5785 gravatar imageBill5785 ( 2017-02-02 08:33:15 -0500 )edit

Yes, that sounds ok. I was just making sure, as the command line you included in your OP used an example path, and that would lead to problems.

gvdhoorn gravatar imagegvdhoorn ( 2017-02-02 08:54:44 -0500 )edit

@gvdhoorn Ok, thanks for your patience :)

Bill5785 gravatar imageBill5785 ( 2017-02-02 09:23:53 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-01-31 08:59:56 -0500

joq gravatar image

You are probably running the Indigo binary version instead of the one you built. Most likely, you forgot to source the devel/setup.bash in your workspace.

edit flag offensive delete link more

Comments

Is there any command to check if mine is "indigo binary version"? I just installed ros by following ros-wiki.

Bill5785 gravatar imageBill5785 ( 2017-02-01 16:28:40 -0500 )edit

Use roscd velodyne_pointcloud and see if it takes you to /opt/ros/ or your workspace.
Use echo $ROS_PACKAGE_PATH to see if your catkin workspace overlay is correctly setup.

kmhallen gravatar imagekmhallen ( 2017-02-02 08:53:07 -0500 )edit

@kmhallen The first output is

wbw@wbw-virtual-machine:~/catkin_ws/src/velodyne/velodyne_pointcloud$

The second output is

/home/wbw/catkin_ws/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks

It seems that the second one is not working well, is that right? I'm new to ros...

Bill5785 gravatar imageBill5785 ( 2017-02-02 09:25:31 -0500 )edit

That output looks fine. The second output means: check /home/wbw/catkin_ws/src first, then check /opt/ros/indigo

kmhallen gravatar imagekmhallen ( 2017-02-03 08:07:45 -0500 )edit

@kmhallen@joq It seems that I need to source devel/setup.bash every time I restart my computer. Is there a way to solve it permanently?

Bill5785 gravatar imageBill5785 ( 2017-02-03 12:28:07 -0500 )edit

If you only use one workspace, you can source it from your ~/.bashrc. For people with multiple workspaces that leads to confusion. I prefer to define short aliases (like ws) that each run an appropriate source command.

joq gravatar imagejoq ( 2017-02-04 10:22:24 -0500 )edit

@joq Thanks, it works! But do you know the solution to my question?

[FATAL] [1486012428.835246258]: Error opening Velodyne socket dump file.
Segmentation fault (core dumped)
Bill5785 gravatar imageBill5785 ( 2017-02-04 10:57:57 -0500 )edit

Don't know for sure. Perhaps you did not pass the full file name path? (That still should not segfault).

joq gravatar imagejoq ( 2017-02-04 14:37:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-01-30 17:14:05 -0500

Seen: 733 times

Last updated: Feb 02 '17