Ask Your Question
1

Velodyne HDL32E sends data, but velodyne_driver gets none

asked 2012-06-10 22:03:51 -0600

Flowers gravatar image

updated 2014-01-28 17:12:38 -0600

ngrennan gravatar image

Hey,

I have an HDL-32E velodyne sensor, but I can't get live data :-)

If I use a file with captured data, everything is just fine and there is no problem(actually the file contains data from the sensor I'm using) - but if I try to run the velodyne_driver with live data, I get a "Velodyne poll() timeout" warning.

I already checked the input.cc file and added a few outputs to the ROS_INFO_STREAM to check, if the driver is listening on the correct port - which it does.

My best guess is, that

poll(fds, 1, POLL_TIMEOUT);

always returns 0, despite the fact, that there is data on Port 2368

Is this some fuerte or ubuntu 12.04 issue?

Update:

Being root doesn't help, but I noticed that there is a bug in Ubuntu 12.04 - you can't use a workspace that is in /home/username

edit retag flag offensive close merge delete

Comments

Is this a problem with putting a ROS workspace some place like /home/username/ros? That works for me. Maybe it should be a separate question, but I wonder exactly how you set up the workspace, and what failed.

joq gravatar image joq  ( 2012-06-11 03:59:54 -0600 )edit

http://answers.ros.org/question/36282/ros-as-root-common-bug-when-in/

There you are - seems to be a linux-related bug, not ros. Still seemed worth reporting.

Flowers gravatar image Flowers  ( 2012-06-11 21:21:31 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-06-11 03:57:02 -0600

joq gravatar image

Network configuration seems to cause frequent problems getting data from the HDL-32E. The older 64E (which I have) is easier because it broadcasts the packets.

According to the HDL-32E Manual, page 11, the 32E only sends data to a specific static IP address, 192.168.3.255.

Exactly how you configure your network depends on your system's network environment. For the simple case of connecting the device directly to an ethernet port, this has been reported to work:

sudo ifconfig eth0  192.168.3.255 netmask 255.255.0.0
edit flag offensive delete link more

Comments

I have try this method, however, it doesn't work. Have you solved this problem? If solved, can you tell me the way?

summer gravatar image summer  ( 2017-12-28 08:06:19 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-06-10 22:03:51 -0600

Seen: 1,472 times

Last updated: Jun 11 '12