Ask Your Question
0

Orbbec Astra on ROS issues

asked 2017-01-16 17:38:12 -0500

Connor gravatar image

updated 2017-01-23 12:32:50 -0500

Recently purchased a Deep Learning Robot. https://www.autonomous.ai/deep-learni... Mine came with the Orbbec Astra instead of the Asus Live Pro. I'm trying to get it up and running but having issues. In RViz, I can see RGB fine, but, the depth sensors don't work when I toggle them on. I'm brand new to ROS and following the Turtlebot tutorials. I found this thread on the subject. https://discourse.ros.org/t/new-depth... but, I'm not exactly sure how to proceed.

More Info:

I'm getting this..

In PointCloud: Transform [sender=unknown_publisher] For frame [camera_rgb_optical_frame]: Fixed Frame [base_footprint] does not exist

In Registerd PointCloud: Transform [sender=unknown_publisher] For frame [camera_rgb_optical_frame]: Fixed Frame [base_footprint] does not exist

also getting these as well

In Grid: For frame [odom]: Fixed Frame [base_footprint] does not exist

RobotModel: Parameter [robot_description] does not exist, and was not found by searchParam()

I ran this on the robot: roslaunch turtlebot_bringup 3dsensor.launch

and this on the PC: roslaunch turtlebot_rviz_launchers view_robot.launch

Thanks, Billy

edit retag flag offensive close merge delete

Comments

Probably not the answer you're looking for, but seeing as you actually bought this configuration from a company: have you tried contacting them and asking this question? We're happy to help, but this would seem like a prime example of the sort of question you'd ask the company's support department.

gvdhoorn gravatar image gvdhoorn  ( 2017-01-17 01:42:26 -0500 )edit

I bought it never assembled from a 3rd party. Not direct from the company. Strange thing is, their site still showing the Asus Axiton Pro Live vs the Orbbec Astra.

Connor gravatar image Connor  ( 2017-01-17 12:29:37 -0500 )edit

In your rviz screen shot (on discourse) it shows status error, If you expand the status (arrow on the left of the status), what is the error?

rohbotics gravatar image rohbotics  ( 2017-01-22 12:47:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2017-01-22 13:37:19 -0500

ahendrix gravatar image

updated 2017-01-22 17:45:55 -0500

There's not a lot for us to go on here.

My typical debugging process would be to ask and answer the following questions:

  • Is there an error displayed in rivz? If you expand the display properties it will show you some status that usually includes number of messages or points received, and sometimes errors.
  • Which topic is rviz subscribing to for "depth sensors" ? This should be listed in rviz display that you're enabling when you try to view the point cloud.
  • Which topics are the Orbbec Astra driver publishing? You can start to identify this by figuring out which node(s) are the Orbbec Astra driver, and then run rqt_graph or rosnode info to see which topics it's publishing
  • Sanity check: Is rviz subscribing to a reasonable topic? Compare the topic that rivz is subscribing to with the list of topics that the driver is publishing.
  • Is there data published on the topic that rviz is subscribing to? Use rostopic echo or rostopic hz to see if there is data published on that topic that rviz is subscribing to
  • If there is data published, why can't rviz display it? This usually goes back to the top, looking at rviz to see why it's not displaying the data.

Please try to go through these steps and answers these questions on your own. If you get stuck, feel free to edit your question with additional information, and please include the details, either copy and paste commands and their output, or include a screenshot of rviz.

EDIT

Given that the transforms for base_footprint is missing and the robot_description parameter is missing, it seems like the main turtlebot launch file isn't running on your robot. I believe this is the minimal.launch in the turtlebot package, but you should consult the manual to be certain.

I also find it odd that you're running rviz on the robot, and the Orbbec driver on your desktop. It seems to be working, but it implies that you're visualizing things on the robot (are you chasing it around with a monitor attached?), while the Orbbec sensor is plugged in to your desktop and, presumably, stationary.

edit flag offensive delete link more

Comments

I cut'n pasted the commands backwards.. I am indeed running rivz on the laptop and the orbbec on the robot. It seems that I missed the VERY critical step of: Make sure the minimal software has already been launched on the robot and you have configured your network correctly.

Connor gravatar image Connor  ( 2017-01-22 18:02:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-01-16 17:38:12 -0500

Seen: 1,148 times

Last updated: Jan 23 '17