Ask Your Question

How to correcly compile and run UM7 downloaded from git

asked 2017-01-14 10:07:25 -0500

Wiew gravatar image


i tried to install UM7 drivers on my RPI with Ubuntu Mate (1.12.1). I installed ros-kinetics library (all). Unfortunatelly, the kinetic package have not um7 library for apt-get. Then i download sources from git ( ), compile and install it.

Simly, steps:

git clone xxxx

mkdir build

cd build

cmake ../ (sucessfully)

make (sucessfully)

make install (sucessfully)

rosrun um7 um7_driver _port:=/dev/ttyAMA0 : [rospack] Error: package 'um7' not found

Any sugestions where is a problem and how to run UM7?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2017-01-14 11:42:49 -0500

gvdhoorn gravatar image

What you did is possible, but I don't recommend it if you just started out.

It's probably easier to create a catkin workspace, put the um7 package in that and build it using catkin_make. If successful, source devel/setup.bash. Then try your rosrun .. command again.

See Creating a workspace for catkin for a tutorial.

edit flag offensive delete link more


Hello.. I am getting error no such file or directory when I do perform rosrun..... command. Followed the same steps as mentioned above.

It would be helpful if I can get pointer to this help

B Dhruva gravatar image B Dhruva  ( 2019-02-13 06:10:56 -0500 )edit

Was the compilation successful? Did you see any errors?

If it was successful: try running rospack profileafer having sourced the devel/setup.bash.

gvdhoorn gravatar image gvdhoorn  ( 2019-02-13 06:14:28 -0500 )edit

Yes compilation was successful. after rospack profile following error. terminate called after throwing an instance of 'std::run time error' what() locale::facet ::_S_create_c_locale name not valid Aborted (core dumped)

it is not able to find package.

B Dhruva gravatar image B Dhruva  ( 2019-02-13 06:25:33 -0500 )edit

Well if rospack throws an error then it wouldn't have run. So effectively the situation hasn't changed.

gvdhoorn gravatar image gvdhoorn  ( 2019-02-13 06:28:30 -0500 )edit

Can you let me know how to debug this? I also tried to install um7 using sudo apt-get install ros-indigo-um7. when I am trying to perform rosrun um7 um7_driver it shows error no file or directory found.

B Dhruva gravatar image B Dhruva  ( 2019-02-13 08:10:39 -0500 )edit

I would guess first make sure the files are actually there, and that um7_driver is actually a binary/ros node.

What is the output of ls -al /opt/ros/indigo/lib/um7?

gvdhoorn gravatar image gvdhoorn  ( 2019-02-13 08:36:19 -0500 )edit

Hello Dhoorn, please find the output below:

administrator@administrator:~$ ls -al /opt/ros/indigo/lib/um7
total 124
drwxr-xr-x  2 root root   4096 Feb 11 05:32 .
drwxr-xr-x 56 root root  12288 Feb 12 07:15 ..
-rwxr-xr-x  1 root root 109720 May 17  2018 um7_driver
B Dhruva gravatar image B Dhruva  ( 2019-02-13 08:40:20 -0500 )edit

Seeing as the node is there and you're running into rospack issues with crashes, I would suggest to post a new question. Please clearly describe what is not working, mention the rospack profile crash, show the ls -al output and refer to this question.

gvdhoorn gravatar image gvdhoorn  ( 2019-02-13 08:44:37 -0500 )edit

#q315560 posted. Thank you :-)

B Dhruva gravatar image B Dhruva  ( 2019-02-13 09:13:33 -0500 )edit

answered 2017-01-25 08:39:44 -0500

Wiew gravatar image

Thank you for your response. Now it seem to be OK. Also, its is necessary run roscore in another console.

I have a one another question. i run a UM7 drivers but i'm not able to see inertial data (i'm able to see only messages like received packet XY without data or sending command zero gyroscopes).

Do you have some solution how to show inertial data (from accelerometers and gyroscopes?)

Thank you for your responce

regards Wiew

edit flag offensive delete link more


Please post a new question for this, as it's not really related to what the OP is about.

gvdhoorn gravatar image gvdhoorn  ( 2017-01-25 09:04:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2017-01-14 10:07:25 -0500

Seen: 352 times

Last updated: Jan 25 '17