Ask Your Question
1

can't locate node [moveit_setup_assistant] in package [moveit_setup_assistant]

asked 2017-01-04 06:29:36 -0500

Lileping gravatar image

updated 2017-01-04 13:08:10 -0500

130s gravatar image

Because the moveit is updated recently.So I use "sudo apt-get remove ros-indigo-moveit" to remove moveit.And then I used "sudo apt-get install ros-indigo-moveit" to reinstall moveit.It can be found in http://moveit.ros.org/install/ .

After that I open a new terminal. I can rospack find moveit_setup_assistant in opt/ros/indigo/share.

But when I run “roslaunch moveit_setup_assistant setup_assistant.launch” It appeared error

ERROR: cannot launch node of type [moveit_setup_assistant/moveit_setup_assistant]: can't locate node [moveit_setup_assistant] in package [moveit_setup_assistant]

After I run "source /opt/ros/indigo/setup.bash" in the terminal.The moveit_setup_assistant works well.

I must source /opt/ros/indigo/setup.bash can I use moveit_setup_assistant.However, after source /opt/...,I can't rospack find the packages in catkin_ws.So after source /opt/...When I run move_group.launch, It appeared error.

ERROR: cannot launch node of type [moveit_ros_move_group/move_group]: can't locate node [move_group] in package [moveit_ros_move_group]

I must source ~/catkin_ws/devel/setup.bash can I use the packages in catkin_ws. However this way I can't use setup_assistant.launch

The bottom lines of my ~/.bashrc file is

source /home/robot508/catkin_ws/catkin_industrial/devel/setup.bash 
source /home/robot508/catkin_ws/le_myself/devel/setup.bash 
source /home/robot508/catkin_ws/devel/setup.bash

When I add the source /opt/ros/indigo/setup.bash to the last line,It also can't work. How can I find the moveit_setup_assistant.launch and move_group.launch at the same time.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-01-04 08:00:51 -0500

130s gravatar image

updated 2017-01-04 08:01:29 -0500

source /home/robot508/catkin_ws/catkin_industrial/devel/setup.bash source /home/robot508/catkin_ws/le_myself/devel/setup.bash source /home/robot508/catkin_ws/devel/setup.bash

First, you're nesting catkin workspace (ie. placing workspaces into another workspace). While it's technically possible (I confirmed that catkin_make runs as intended for each workspace), I suggest not do that unless you really need to and you know what you're doing, because this may cause unexpected result (instead the normal way to use multiple catkin workspaces is to place each separately).

And your issue sounds like your catkin workspace might not be configured as it's supposed to. Remove build and devel folders in %YOUR_CATKIN_WS% and run catkin_make, source the setup again to see if it works. Your uncommon workspace setting might have done something funky so again I suggest you fix it.

If the issue persists you need to share more info esp. env|grep ROS.

edit flag offensive delete link more

Comments

Thank you very much. You are right. The nesting catkin workspace is uncommon. I rebuild my catkin workspace and now moveit works well. Thanks a lot

Lileping gravatar image Lileping  ( 2017-01-05 03:15:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-01-04 06:29:36 -0500

Seen: 1,195 times

Last updated: Jan 04 '17