Ask Your Question
0

I cannot convert xacro file to urdf

asked 2017-01-01 08:48:27 -0500

patrchri gravatar image

updated 2017-01-01 08:49:01 -0500

Hello,

I have an issue about broadcasting some links at tf for which I have asked here. Someone commented that he solved my issue from converting the xacro file to a urdf one. How can I do that?

I have searched for the issue in questions like here and here and when I type:

rosrun xacro xacro.py rover_ws/src/labrob/labrob_description/urdf/labrob.urdf

or

rosrun xacro xacro.py 'rover_ws/src/labrob/labrob_description/urdf/labrob.urdf'

I get an error like the following:

xacro: Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see http://wiki.ros.org/xacro#Processing_Order
No such file or directory: rover_ws/src/labrob/labrob_description/urdf/labrob.urdf
XacroException('No such file or directory: rover_ws/src/labrob/labrob_description/urdf/labrob.urdf',)

The directory is the correct one I am writting here, I don't know what I am doing wrong. Could you please help me?

Thanks for your answers and time in advance,

Chris

PS: I am in ROS Kinetic

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-01-01 11:44:00 -0500

NEngelhard gravatar image

did you try it with an absolute path?

edit flag offensive delete link more

Comments

Thank you the command worked with the absolute path...if you would like add this as an answer to accept it...Your suggestion at my other question didn't work though with the converted urdf...I still get a wrong tree.

patrchri gravatar image patrchri  ( 2017-01-01 12:19:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-01-01 08:48:27 -0500

Seen: 905 times

Last updated: Jan 01 '17